Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

количество натуральных чисел которые удовлетворяют условия 22х+14у=8456

10-11 класс

Gasanovadiana1 28 дек. 2016 г., 8:53:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ШуНка
28 дек. 2016 г., 10:50:03 (7 лет назад)

во-первых, поделим все на 2
11х+7у  = 4228
у = (4228-11х)/7 = 4228/7-11х/7 = 604 - 11х/7
чтобы у был натуральным - то есть положительным и целым - 11х/7 должно быть натуральным числом меньше 608
если
11х/7 = 608, то
х = 608*7/11
х = 386,9
значит Х должен быть меньше 387 и кратным 7
385/7 = 55 то есть

то есть есть 55 пар решений этого равенства:
в них х принимает значения от 7*1 до 7*55, а игрек - от
604-11*1 до 604-11*55

11 и 7 - простые числа, значит ни одно из значений х не равно значению у

то есть 55+55 = 110 натуральных чисел удовлетворяют условиям задачки: 55 для У и 55 для Х.

Ура!)

+ 0 -
Busovaanna
28 дек. 2016 г., 11:36:48 (7 лет назад)

const
    a = 22;
    b = 14;
    c = 8456;

var
    x, y, k: integer;

begin
    for x := 0 to c div a do
        for y := 0 to c div b do
            if a * x + b * y = c then begin
                k := k + 1;
                writeln(k:2, ' ', x:4, ' ', y:4);
            end;
    
    writeln(k);
end.

Ответ 55, если натуральные числа содержат 0 и 54 если нет

Ответить

Другие вопросы из категории

Дан одномерный массив из 10 следующих элементов:

3,0,1,7,4,5,6,2,9,0.

Как изменится порядок элементов после выполнения фрагмента Паскаль-программы описанного ниже?

...
for i:=1 to 5 do
begin
t:=a[i];
a[i]:=a[11-i];
a[11-i]:=t;
end;
...

Современные видеокарты могут поддерживать разрешение 2560*1600 пикселей при глубине цвета 32 бит

Размер буфера кадра при этом равен 16 Mb
Вопрос : Какая пропускная способность шины потребуется, чтобы вывести такой буфер кадра на монитор с частотой 75 Hz?

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "количество натуральных чисел которые удовлетворяют условия 22х+14у=8456", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.