Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

даю 30 баллов. Наибольшим общим делителем (НОД) для двух целых чисел m и n называется наибольший из их общих делителей. Например, для чисел 70 и 105

5-9 класс

наибольший общий делитель равен 35.


Вам заданы целые неотрицательные a и b (0 ≤ a,b ≤ 109). Напишите программу, которая выведет количество вычитаний при работе такого алгоритма и результат его работы.


Входные данные
Единственная строка входных данных содержит записанные через пробел целые числа a, b (0 ≤ a,b ≤ 109).


Выходные данные
Выведите количество вычитаний в ходе работы алгоритма и его результат через пробел.

вот мое решение но я не набираю все баллы значит ошибка есть помогите исправить

var
a,b,k:longint;
begin
read(a,b);
k:=1; // или (k:=0;)
if (a=0) and (b=0) then k:=0 else
while a<>b do begin if a>b then a:=a-b else b:=b-a ;inc(k); end; writeln(k);writeln(a);

end.

KaTe105 01 сент. 2015 г., 11:30:16 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lil7176
01 сент. 2015 г., 13:16:49 (8 лет назад)

А если а и б равны друг другу изначально, и при этом не нуль
Тогда получается, что у тебя якобы 1 действие выполнилось, но на самом деле ничего не сделалось. Вот в этом возможно и есть ошибка

Ответить

Другие вопросы из категории

Расположите величины в порядке возрастания :

1010байтов; 2байта; 1Кбайт; 20 битов; 10 битов

Даны простые высказывания: А=(5<3), B= (2=3) и C = (4>2)

определить истинность составного высказывания:
(A and B) or C<--> (A or C) and (A and B)

Подробное решение, пожалуйста!

Читайте также

Помогите,пожалуйста с тестом по информатике! Это срочно! Даю 30 баллов!

1.Примером документальной базы данных является база данных,содержащая:
а)законодательные акты
б)Сведения о кадровом составе учреждения
в)Сведения о финансовом состоянии учреждения
2.База данных - это...
3.Примером иерархической базы данных является
а)Страница классного журнала
б)Каталог файлов,хранимых на диске
в)Расписание поездов
г)Электронная таблица
4.Наиболее точным аналогом реляционной базы данных может служить:
а) Неупорядоченное множество данных
б) Вектор
в) Генеалогическое древо
г) Двумерная таблица
5. Поля реляционной базы данных
а) Именуются пользователем произвольно с определенными ограничениями
б) Автоматически нумеруются
в) Именуются по правилам,специфичным для каждой конкретной СУБД
г) Нумеруются по правилам,специфичным для каждой конкретной СУБД
6.Структура реляционной базы данных меняется при удалении:
а) Одного из полей
б) Одной записи
в) Нескольких записей
г) Всех записей
7.В записи реляционной базы данных может содержаться:
а) Неоднородная информация(данные разных типов)
б) Исключительно однородная информация(данные только одного типа)
в) Только текстовая информация
г) Исключительно числовая информация
8. Значение выражения 0,7-3>2 относится к следующему типу данных:
а) Числовому
б) Логическому
в) Строковому
г) Целому
9. Система управления базами данных(СУБД) - это...
10. Модель отражает:
а) Все существующие признаки объекта
б) Некоторые из всех существующих
в) Существенные признаки в соответствии с целью моделирования
г) Некоторые существенные признаки объекта
д) Все существенные признаки
11. При описании отношений между элементами системы удобнее всего использовать информационную модель следующего типа:
а) Текстовую
б) Математическую
в) Структурную
г) Табличную
д) Графическую
12. Понятие модели имеет смысл при наличии:
а) Моделирующего субъекта и моделируемого объекта
б) Цели моделирования и моделируемого объекта
в) Моделирующего субъекта;цели моделирования и моделируемого объекта
г) Цели моделирования и двух различных объектов
д) Желания сохранить информацию об объекте
13. Рисунки,карты,чертежи,диаграммы,схемы,графики представляют собой модели следующего вида:
а) Табличные информационные
б) Математические модели
в) Натурные
г) Графические информационные
д) Иерархические информационные
14. Суть основного тезиса формализации состоит в принципиальной возможности:
а) Представления информации на материальном носителе
б) Передачи информации от одного объекта к другому
в) Обработка информации человеком
г) Хранение информации в памяти компьютера
д) Разделение объекта и его обозначения

ПОМОГИТЕ ПОЖАЛУЙСТА,ДАЮ 30 БАЛЛОВ!

Составьте программу ,которая формирует массив ,содержащий 12 случайных вещественных чисел ,принадлежащих промежутку от [-10;30] , и подсчитывает произведение всех отрицательных чисел. Вывод в столбец с тремя десятичными знаками.

Нужен программный код для Паскаль.

Для последовательности целых чисел а, b, c все четные числа разделите на 2. Нечетные оставьте без изменений.



Вы находитесь на странице вопроса "даю 30 баллов. Наибольшим общим делителем (НОД) для двух целых чисел m и n называется наибольший из их общих делителей. Например, для чисел 70 и 105", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.