Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1)Напишите программу, которая считает количество четных цифр введенного числа 2) Напишите программу, которая вводит с клавиатуры натуральное число N и

10-11 класс

определяет его факториал, т.е. произведение натуральных чисел от 1 до N: N!=1×2×3×...×N. Что будет, если ввести большое значение N (например, 20)? 3) Напишите программу, которая вводит натуральные числа A и N и вычисляет A^N.

Ackimowa 07 окт. 2016 г., 17:38:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikal123
07 окт. 2016 г., 20:31:47 (7 лет назад)

1)
var
  a, b: integer;

begin
  readln(a);
  foreach e: char in a.ToString() do //Проходит по каждому символу в строке, полученной путём преобразования числа
    if (Byte.Parse(e) mod 2 = 0) then
      inc(b); //Увеличивает значение на 1
  writeln(b);
end.
====================== 2 в файле
3)
var
  a, n: integer;

begin
  readln(a, n);
  writeln(power(a, n)); //power возводит число в указанную степень
end.

Ответить

Другие вопросы из категории

Помогите решить.Массивы Паскаль. Имеется массив А из N произвольных чисел А(N), среди которых есть положительные, отрицательные и равные нулю. Вычислить

количество чисел, квадрат которых меньше 10. Так, если А={2,4,–3,3,5,–2,1}, результат: 5 (это числа 2, –3, 3, –2, 1).

Чему равен sin(x) в Паскале?
Исполнитель Робот действует на клетчатой доске, между соседними клетками которой могут стоять стены. Робот передвигается по клеткам доски и может

выполнять команды 1 (вверх), 2 (вниз), 3 (вправо) и 4 (влево), переходя на соседнюю клетку в направлении, указанном в скобках. Если в этом направлении между клетками стоит стена, то Робот разрушается. Робот успешно выполнил программу 41444231.

Какую последовательность из четырех команд должен выполнить Робот, чтобы вернуться в ту клетку, где он был перед началом выполнения программы, и не разрушиться вне зависимости от того, какие стены стоят на поле?

Читайте также

1)Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.

2)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
3)Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.
4)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.



Вы находитесь на странице вопроса "1)Напишите программу, которая считает количество четных цифр введенного числа 2) Напишите программу, которая вводит с клавиатуры натуральное число N и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.