Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить.Массивы Паскаль. Имеется массив А из N произвольных чисел А(N), среди которых есть положительные, отрицательные и равные нулю. Вычислить

10-11 класс

количество чисел, квадрат которых меньше 10. Так, если А={2,4,–3,3,5,–2,1}, результат: 5 (это числа 2, –3, 3, –2, 1).

Adik1000500 21 сент. 2016 г., 12:45:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetik17
21 сент. 2016 г., 14:46:38 (7 лет назад)

uses crt;
var
a:array [1..100] of real;
i,n,k:integer;
begin
write('Введите количество чисел массива: '); read(n);
clrscr;

writeln('Массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
if (sqr(a[i])<10) then k:=k+1;
write(a[i],' ');
end;
writeln;
write('Количество чисел, квадрат которых меньше 10: ',k);
end.

Ответить

Другие вопросы из категории

Чему равен sin(x) в Паскале?
Исполнитель Робот действует на клетчатой доске, между соседними клетками которой могут стоять стены. Робот передвигается по клеткам доски и может

выполнять команды 1 (вверх), 2 (вниз), 3 (вправо) и 4 (влево), переходя на соседнюю клетку в направлении, указанном в скобках. Если в этом направлении между клетками стоит стена, то Робот разрушается. Робот успешно выполнил программу 41444231.

Какую последовательность из четырех команд должен выполнить Робот, чтобы вернуться в ту клетку, где он был перед началом выполнения программы, и не разрушиться вне зависимости от того, какие стены стоят на поле?

Читайте также

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти

величину наибольшего среди отрицательных чисел этой последовательности.

Помоги решить, программа Паскаль

1. для чисел равных 5 от 1 до N вывести квадрат числа,для остальных вывести "не кратно 5"
2.посчитать сколько из 15 произвольно веденных чисел,чисел больше 15
3. для любого количества произвольных чисел найти сумму положительных

Составить блок-схему решения задачи:

Дан массив, состоящий из 10 произвольных чисел. Найти среднее геометрическое этих чисел.



Вы находитесь на странице вопроса "Помогите решить.Массивы Паскаль. Имеется массив А из N произвольных чисел А(N), среди которых есть положительные, отрицательные и равные нулю. Вычислить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.