Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти

10-11 класс

величину наибольшего среди отрицательных чисел этой последовательности.

123456789йцукен 26 июня 2013 г., 15:29:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nigora9898
26 июня 2013 г., 16:37:48 (10 лет назад)

var
  x,max:real;
  n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
  begin
  write('Введите число ',i,': ');
  readln(x);
  if x<0 then
     begin
     if max=0 then max:=x;                     // если это первое отр.число
     if x>max then max:=x
     end
  end;
writeln('Наибольшее среди отрицательных: ',max)
end.

Ответить

Другие вопросы из категории

Напишите программу либо visual fox pro, либо блок-схемой

по задаче: определить отдельно рост учеников в классе(кол-во учеников "N"-вводится вручную)
я голову всю переломала, хотя бы примерно

Суперкенгуру может прыгать по прямой вправо и влево и совершать гигантские прыжки. Длина его первого прыжка составляет 1 м, второго — 2 м, третьего — 4 м

и так далее (длина каждого прыжка всегда в два раза больше, чем предыдущего). Через какое минимальное количество прыжков суперкенгуру окажется на расстоянии d метров от исходной точки O?

вычесть двоичное число 110111-11011=
помогите решить вторую..

1. Даны три числа а, b, с. Удвойте эти числа, если они являются упорядоченными по возрастанию.
2. Проверьте, есть ли среди трех заданных чисел равные.

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Написать Программу в паскале которая посчитала бы 5^123 (это цикл как бы должен быть)

http://primat.org/index/0-128 вот сайт что бы написать программу.



Вы находитесь на странице вопроса "Написать программу в паскале: Даны целое n&gt;0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.