Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите решить вторую..

10-11 класс

1. Даны три числа а, b, с. Удвойте эти числа, если они являются упорядоченными по возрастанию.
2. Проверьте, есть ли среди трех заданных чисел равные.

Mariyapimenova 06 июня 2013 г., 0:44:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katenka2111
06 июня 2013 г., 1:36:23 (10 лет назад)

Решается и первая и вторая

Вывод на скриншотах

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

bool check(int, int);

int main()
{
   int a, b, c;

   cout << "Enter a, b, c: "; //Вводить через пробел
   cin >> a >> b >> c;

   //Проверка на упорядоченность
   if(a <= b && b <= c)
   {

      //Если числа являются упорядоченными,

      // то вывести на экран удвоенные значения
      cout << "The numbers are ordered:\n";
      cout << (a * 2) << ' ' << (b * 2) << ' ' << (c * 2) << endl;
   }
   else
      cout << "The numbers are not ordered" << endl;

   //Проверка на равенство
   if(check(a, b) || check(b, c) || check(a, c))
   {
      cout << "There are equal numbers" << endl;//Есть равные числа
   }
   else
      cout << "Equal numbers are not" << endl;//Нет равных чисел
   return 0;
}


bool check(int x, int y)
{
   if(x == y)
   {
      return true;
   }
   else
      return false;
}

 

 

Ответить

Другие вопросы из категории

C(10) Определить наименьший элемент массива С и его номер, С<0

Ребзя, помогите плиз

Доброго вечера.

Необходимо написать программу на JS, которая бы выводила две гиперссылки на некоторые сайты, а затем определяла бы время в секундах между щелчками мыши на эти самые гиперссылки и на какую именно гиперссылку кликнули в первый раз.
Заранее спасибо.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Помогите решить задачу в паскале.Дана

строка символов р1, р2,
..., рn. Определить число вхождений в последовательность группы
букв "xyz". Вырезать
фрагмент из текста между первым и вторым вхождением группы символов "xyz".

Помогите решить в паскаль.

По древней легенде мудрец, который изобрел шахматы, потребовал от персидского шаха такое количество пшеницы, чтобы им можно было покрыть шахматную доску, положив на первую клетку 1 зерно, на вторую - 2, на третью - 4 и т.д., т.е. на каждую следующую в двое больше предыдущей. Каким количеством зерна можно покрыть шахматную доску?




Вы находитесь на странице вопроса "помогите решить вторую..", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.