Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан год. Вывести на экран название животного, символизирующего заданный

10-11 класс

год по восточному календарю. Выполнить надо желательно с оператором case.

Nahapetyans 03 сент. 2016 г., 4:23:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katyakas1
03 сент. 2016 г., 4:57:22 (7 лет назад)

var
  y:integer;
  s:string;
 
begin
  Write('Введите год (800-3000): ');
  Readln(y);
  y:=(y-800) mod 12;
  case y of
  0:s:='Дракон';
  1:s:='Змея';
  2:s:='Лошадь';
  3:s:='Коза (овца)';
  4:s:='Обезьяна';
  5:s:='Петух';
  6:s:='Собака';
  7:s:='Свинья (кабан)';
  8:s:='Крыса (мышь)';
  9:s:='Бык (корова)';
  10:s:='Тигр';
  11:s:='Кролик (заяц, кот)';
  end;
  Writeln(s)
end.

Тестовое решение:

Введите год (800-3000): 2031
Свинья (кабан)


Ответить

Другие вопросы из категории

Элементы массива А[i], состоящего из 20 элементов, получить по формуле 2*i^2-12*i+20 Написать программу, которая может: 1) вывести на экран все

элементы получившегося массива; 2) найти минимальный и максимальный элементы; 3) вывести на экран элементы массива в обратном порядке.

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Даны действительные числа x, y. Вывести на экран то из них, которое меньше.

Даны два символа (латинские буквы). Вывести их на экран в порядке возрастания по алфавиту.

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.



Вы находитесь на странице вопроса "Дан год. Вывести на экран название животного, символизирующего заданный", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.