Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Создать программу в паскалеНахождения суммы и произведения трехзначного числа. Сказали, что еще пригодиться эта формула: z: = (adiv10)mod10

5-9 класс

Заранее спасибо^.^

Snegaklass 13 янв. 2014 г., 21:49:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vlavlavla
14 янв. 2014 г., 0:20:15 (10 лет назад)

var
  number, first, second, third : integer;
begin
  readln(number);
  first := number div 100;
  second := number div 10 mod 10;
  third := number mod 10;
  writeln('Сумма: ', first + second + third);
  writeln('Произведение: ', first * second * third);
end.

+ 0 -
543101998
14 янв. 2014 г., 1:10:35 (10 лет назад)

2 минуты

+ 0 -
Esf222
14 янв. 2014 г., 1:46:34 (10 лет назад)

Спасибо, очень жду

+ 0 -
Ksjdnfhvjchdndndnd
14 янв. 2014 г., 3:31:21 (10 лет назад)

Число вводится или так существует?

+ 0 -
Zari12345
14 янв. 2014 г., 4:52:27 (10 лет назад)

Ладно, пускай будет вводиться

+ 0 -
Fackerty
14 янв. 2014 г., 7:13:11 (10 лет назад)

вводится

Ответить

Другие вопросы из категории

Системные оболочки – это:

1. специальная кассета для удобного размещения дискет с операционной системой
2. специальная программа, упрощающая диалог пользователь – компьютер,
выполняет команды операционной системы
3. система приемов и способов работы конкретной программы при загрузке программ
и завершении работы

Допишите команду if.....Then.....else.... для решения задачи:

Если число х больше 139, то увеличить его в 74 раза, и уменьшить на 48 в противном случае.

Читайте также

Написать программу, вычисляющую квадрат суммы двух введенных чисел.

(написать на языке программы паскаль, и если кто забыл, то квадрат суммы это - квадрат первого числа плюс удвоенное произведение первого на второе плюс квадрат второго числа )

Написать программу,которая вычисляет сумму первых n членов ряда 1,3,5,7. Количество суммируемых членов ряда задаётся во время роботы программы.

(ниже представлен рекомендуемый вид экрана во время работы программы)
Вычисление частичной суммы рада 1,3,5,7.
Введите количество суммируемых членов ряда: 15
Сумма первых 15 членов ряда равна 330.

1. Если дано трехзначное число, например 123 его можно представить в

виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу,
которая, получая от пользователя трехзначное число, будет определять из каких цифр
оно состоит и выводить их через пробел (например, 1_2_3).

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо



Вы находитесь на странице вопроса "Создать программу в паскалеНахождения суммы и произведения трехзначного числа. Сказали, что еще пригодиться эта формула: z: = (adiv10)mod10", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.