Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны числа от 1 до n.найти сумму всех чисел.произведеие всех чисел и среднее арифметическое. Помогите пожалуйста,прошу!

5-9 класс

журавль77 13 янв. 2017 г., 4:25:54 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vika20040131
13 янв. 2017 г., 6:22:06 (7 лет назад)

var n,i:byte;
p,s,r:real;

begin
s:=0;p:=1;
write('Введите n = ');
readln(n);
for i:=1 to n do begin
readln(r);
s:=s+r;
p:=p*r;
end;
writeln('Cумма всех чисел s = ',s:0:4);
writeln('Произведение всех чисел p = ',p:0:4);
writeln('Cреднее арифметическое = ',(s/n):0:4);
end.

 

+ 0 -
Marymisch55
13 янв. 2017 г., 7:38:16 (7 лет назад)

var a,n,i,s,pr: integer;

begin

  a:=1;

  s:=0;

  pr:=1;

  readln(n);

  for i:=1 to n do begin

    s:=s+a;

    pr:=pr*a;

    a:=a+1;

                         end;

  writeln('Сумма: ',s,', произведение: ',pr,', среднее арифметическое: ',s/n:0:3);

end.

    

 

Ответить

Другие вопросы из категории

Читайте также

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

1. Даны числа от 5 до 16. Необходимо вывести на экран (в столбик) удвоенное значение каждого числа.

Пример вывода ответа: 5*2 = 10
6*2 = 12 и т.д.
2) Напишите программу перевода расстояния из метром в сантиметры для значений длин от 1 до 15 метров.

(Информатика. 8 класс. Паскаль)



Вы находитесь на странице вопроса "Даны числа от 1 до n.найти сумму всех чисел.произведеие всех чисел и среднее арифметическое. Помогите пожалуйста,прошу!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.