Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Begin

10-11 класс

a:=2;

оcsaна 18 мая 2013 г., 21:39:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vovamolotkov70
19 мая 2013 г., 0:33:14 (10 лет назад)

все достаточно просто. у тебя дан цикл for. на первом шаге a = 2. и все,дальше просто идешь по циклу, i от 1 до 4. на первом круге  i = 1,по этому a = a * i + i то есть a = 2 * 1 + 1 и того а = 3 а i = 1 потому эта переменная не меняется. Ну и так далее. второй круг a = 3* 2 + 2 a = 8 i = 2. потом a= 8*3+3 a= 27 i = 3. Ну и в конце a = 27* 4 + 4 a= 112 i = 4. по этому и получается

a   i
3   1
8    2
27   3
112  4

+ 0 -
витютнева
19 мая 2013 г., 2:13:03 (10 лет назад)

a   i
3   1
8   2
27  3
112 4

Вот как то так :)
Если помогла - оцени :з

Ответить

Другие вопросы из категории

Помогите сделать

Пожалуйста срочно

Укажите верный адрес ячейки электронной таблицы Microsoft Excel?

А)45А
В)2000
С)АВС5
D)12СВА

даны три натуральных числа, являющиеся длинами сторон треугольника. Число ввести с клавиатуры. Определить является ли треугольник прямоугольным,

если эти отрезки позволяют его построить. Написать программу на паскале только на паскале и не на другом языке!!!

Читайте также

1. Сколько раз будут выполнены инструкции между begin и end?k:=5;

for i:=k to k+1 do
begin

end;

Что делает следующая программа? program Whatlslt; var f: file of integer; i: integer; begin reset( f ); while not e

of( f ) do begin read( f, i );

writeln( i );

end;

close(f);

end.

1) выводит в столбик числа, записанные в файле;

2) выводит в строку числа, записанные в файле;

3) записывает числа в новый файл;

4) дописывает числа в существующий файл.

Const m= 1000; var z:Array [1..m] of record x,y:real end; n,i,j: integer; r,k,c,d: real; begin write('Ââåäèòå êîëè÷åñòâî ñòàíöèé: '); Readln(n); for i:=1

to n do begin write('Ââåäèòå êîîðäèíàòû ',i,' ñòàíöèè (x y): '); Readln(z[i].x,z[i].y) end; r:=0; for i:=1 to n do for j:=i+1 to n do begin d:=(z[i].x+z[j].x)/n; c:=(z[i].y+z[j].y)/n; if d



Вы находитесь на странице вопроса "Begin", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.