Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите , пожалуйста. Задача пр информатике. Изучили операторы for, if ,while , repeat . Составьте программу , пожалуйста. Если на одну чашу весов

10-11 класс

посадить мальчика , который весит n - кг , а на др. чашу весов насыпать n-кг конфет , к мальчику посадить девочку , которая весит на 5 кг меньше , а конфеты гораздо тяжелее детей , сколько необходимо съесть конфет детям , чтобы чаши весов уравновесились ?

Siniczinvolodi 14 июня 2015 г., 5:17:46 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alfadog777
14 июня 2015 г., 7:37:56 (8 лет назад)

var
 n,m,i:integer;
 begin
 write('Введие вес мальчика: ');
 readln(n);
 write('Введите массу конфет (кг): ');
 readln(m);
 i:=0;
 while n+n-5<>m do
 begin
   i:=i+1;
   m:=m-1;
 end;
 writeln('Детям необходимо сьесть ',i,' кг конфет');
 end.

Ответить

Другие вопросы из категории

Помогите пожалуйста !!!

Упростить
1)(A&B)v(A&неB)
2)(не A&B)v(A&B)
3)(AvB)&(не AvB)
4)(AvB)&(AvнеB)

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Помогите , пожалуйста. Задача пр информатике. Изучили операторы for, if ,while , repeat . Составьте программу , пожалуйста. Если на одну чашу весов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.