Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших

10-11 класс

разрядах данного числа. Пример. N = 1020000. Количество нулей равно четырем.

аннаникита 03 мая 2014 г., 16:33:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Grom19891989198
03 мая 2014 г., 18:31:32 (10 лет назад)

var N,i:integer;
begin
readln(n);
while (n mod 10=0) do begin inc(i); n:=n div 10; end;
writeln(i);
end.

Ответить

Другие вопросы из категории

Взять три своих инициала и закодировать( К С Б, где А=12, Б=13, В=14 и т.д) Полученные три числа перевести в двоичную систему счисления, вычислить их

сумму и перевести в десятичную систему счисления. Эти три числа перевести в восьмеричную систему , вычислить их сумму и перевести в десятичную систему счисления. Эти три числа перевести в шестнадцатиричную и вычислить их сумму, и перевести в десятичную

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

Помогите, пожалуйста написать программу на паскаль

Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).



Вы находитесь на странице вопроса "Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.