Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

C начала 1990 года по некоторый день прошло n месяцев и 2 дня. Определить название месяца этого дня, написать программу в pascal (case of) и (if

5-9 класс

else), подскажите хотя бы алгоритм решения!

Liluars 24 апр. 2015 г., 15:03:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sonya0408
24 апр. 2015 г., 16:31:50 (9 лет назад)

var
  A: System.DateTime;
  i: byte;
  
begin
  readln(i);
  A := (new System.DateTime(1990, 1, 1)).AddMonths(i).AddDays(2);
  case A.DayOfWeek of
    System.DayOfWeek.Monday: writeln('ПН');
    System.DayOfWeek.Tuesday: writeln('ВТ');
    System.DayOfWeek.Wednesday: writeln('СР');
    System.DayOfWeek.Thursday: writeln('Чт');
    System.DayOfWeek.Friday: writeln('ПТ');
    System.DayOfWeek.Saturday: writeln('СБ');
    System.DayOfWeek.Sunday: writeln('ВС');
  end;
end.

Ответить

Другие вопросы из категории

Помогите распределить слова на две группы:общие понятия и единичные. Или объясните что озночают общие и единичные понятия.

вот слова:число,столица России,учебник,наука,житель Москвы,столица,самая высокая гора,А.С.Пушкин,сказочный персонаж,Змей Горыныч.

Читайте также

задача по информатике, составить блок-схему алгоритма и программу для решения задачи: спортсмен - лыжник начал тренировки пробежав в первый день 10 км,

каждый следующий день он увеличивал длину на Р% от пробега предыдущего дня, определить после какого дня суммарный пробег лыжника превысит 200 км. вывести найденное кол-во дней и их суммарный пробег.

1) Скорость передачи данных по некоторому каналу связи равна 512 Кбит/с. Передача файла по этому каналу связи заняла 4 мин. Определите размер файла в

мегабайтах.

2) Скорость передачи данных по некоторому каналу связи равна 32 Кбит/с. Передача текстового файла по этому каналу связи заняла 15 с. Определите, сколько страниц содержал переданный текст, если известно, что иформационный вес одного символа равек 8 битам, а на одной странице 48 символов.

3) Скорость передачи данных по некоторому каналу равна 64000 бит/с. Передача файла по этому каналу связи заняла 16 с. Определите размер файла в килобайтах.

хотя бы первую решите....

С пояснениями пожалуйта .. Буду очень признательна

написать программу в Pascal и составить её блок -схему: по возрасту, введённому с клавиатуры, определить, к какой возрастной группе относится человек:

от 0 до 7 лет дошкольник. от 8 до 17 лет школьник, от 18 до 23 лет студент, 24-55 лет работник, от 56 лет и старше пенсионер.



Вы находитесь на странице вопроса "C начала 1990 года по некоторый день прошло n месяцев и 2 дня. Определить название месяца этого дня, написать программу в pascal (case of) и (if", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.