Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

с клавиатуры вводится строка из нескольких символов разделенных одним или несколькими пробелами.определите количество слов в строке

5-9 класс

Dey1ner 24 июля 2015 г., 19:02:24 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Оля2595
24 июля 2015 г., 21:34:47 (8 лет назад)

 Var s:string;
i,c,b,x:integer;
begin
b:=0;
c:=0;
x:=0;
readln(s);
x:=(length(s)) +1;
s[x]:=' ';
for i:=1 to x do begin
if(s[i]<>' ') then inc(b)
else if(s[i]=' ') and (b>0) then begin inc(c); b:=0; end;
end;
writeln(c);
end.

Ответить

Читайте также

ПОМОГИТЕ С ПРОГРАММОЙ. Язык #паскаль.

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими). Вывести строку, содержащую эти же слова, разделенные одним символом "."(точка). В конце строки точку не ставить.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

1)книга содержит 130 страниц.40 строк по 50 символов на каждой странице.найти информационный объем книги набраной на ПК в Кбайт(результат округлить до

десятых)

2)информационное сообщение объемом 50 байт состоит из 100 символов.найти количество символов в алфавите

3)какое определение для понятия наука информатика является лишним?а)информация б)прием в)процессор г)обработка д)передача е)хранение

объяснить ответ

Помогите Решить 4 любые задачи:

1)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Сколько элементов последовательности превышает число 100?
2)Вводится последовательность из 10 вещественных чисел. Вычислить сумму элементов, не превышающих числа А.
3)С клавиатуры вводится последовательность из 7 целых чисел. Определить каких чисел больше: четных или нечетных.
4)С клавиатуры вводится последовательность из 9 чисел. Найти разность между макимальным и минимальным элементами.
5)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер отрицательного элемента, если считать элементы справа. В случае нескольких отрицательных элементов вывести номер последнего из них (т.е. самого правого).
6)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер первого двузначного элемента последовательности, считая элементы в прямом порядке.
7)С клавиатуры вводится последовательность положительных чисел, оканчивающаяся 0. Найти сумму двузначных элементов последовательности.
8)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти произведение отрицательных элементов последовательности.
9)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти в ней минимальный элемент.
10)С клавиатуры вводятся числа 2, 5 или 10, означающие удаления игроков на соответствующее кол-во минут. Условно положительные значения означают удаления в команде А, а отрицательные - в команде В. Для завершения ввода данных используется 0. Сколько всего штрафного времени заработано командами А и В отдельно, а также определить общее штрафное время.



Вы находитесь на странице вопроса "с клавиатуры вводится строка из нескольких символов разделенных одним или несколькими пробелами.определите количество слов в строке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.