Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Натуральное число из n является числом Армстронга т.е сумма его цифр возведенная в n степень, равна самому числу (153=1*1*1+5*5*5+3*3*3). Получить все

10-11 класс

числа Армстронга для n=4, n=3.

Лисеночек 21 февр. 2017 г., 14:39:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
GotDog
21 февр. 2017 г., 16:57:59 (7 лет назад)

Uses crt;
Var
         n,n1,n2,n3,n4,i,Armst:integer;
Begin
   Write('Введите n: '); readln(n);
   Write('Числа Армстронга 

+ 0 -
Konk3y1
21 февр. 2017 г., 19:25:47 (7 лет назад)

Какой язык?

+ 0 -
Lovesonia
21 февр. 2017 г., 20:40:10 (7 лет назад)

незнаю

+ 0 -
Irinka1498
21 февр. 2017 г., 21:40:49 (7 лет назад)

В смысле не знаешь? На каком языке программирования тебе нужно решить эту задачу?

+ 0 -
Viktorya31
21 февр. 2017 г., 22:14:56 (7 лет назад)

Турбо Паскаль

Ответить

Другие вопросы из категории

информатика! итоговая спасите
Сколько существует

(невырожденных) треугольников периметра N с целыми длинами сторон? (Треугольник со сторонами a,b,c называется невырожденным, если из отрезков длины a,b,c его можно составить.)
Входные данные, С клавиатуры вводится число N (1 \leq N \leq 1000)/
Выходные данные, Программа выводит число таких треугольников.

Какие двоичные, восьмеричные и шестнадцатеричные числа соответствуют данным десятичным: 128,256,512,1024,2,7,17,68,315,765,2047.

Чему в десятичной, восьмеричной и шестнадцатеричной системе равны следующие двоичные числа : 1000001, 101, 11101, 101010, 100011, 10110111011, 10000001, 100000001

Переведи в десятичную CC
75(8); B4(16); 213(5); 613(8); 16(16); 14(9); AFC10(16); 10765(8); F026(16)

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в К- ю степень( где К- количество цифр в числе) равна самому числу.

Например, 153=1³ + 5³ + 3³.
Входная строка содержит два натуральных числа- значения а и б.
Входные данные
Входная строка содержит два натуральных числа - значения а и б, разделенных пробелами. Гарантируется, что а≥б.
Выходные данные
Программа должна вывести в одну строчку все числа Армстронга на отрезке а, б, разделив их пробелами. если таких чисел нет, программа должна вывести -1.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!



Вы находитесь на странице вопроса "Натуральное число из n является числом Армстронга т.е сумма его цифр возведенная в n степень, равна самому числу (153=1*1*1+5*5*5+3*3*3). Получить все", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.