Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.

10-11 класс

На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

Isaevsavva 16 июня 2013 г., 21:54:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
эшлин
17 июня 2013 г., 0:41:10 (10 лет назад)

var
a:array [1..100] of integer;
i,n,k,mx:integer;
begin
  writeln('Введите n:');
  readln(n);
  mx:=1; k:=0;
  writeln('Введите массив:');
  for i:=1 to n do
  begin
  readln(a[i]);
  if a[i]>a[mx] then
  begin
  mx:=i;
  k:=0;
  end else
  if (a[i]=a[mx])and(i<>mx) then k:=k+1;
  end;
  writeln('Количество элементов массива равных максимальному: ',k);
end.

Ответить

Другие вопросы из категории

Помогите решить срочно
пожалуйста, скорее....

составить программу которая найдет номер максимального элемента (массив из 10 случайных чисел)

Дан Двумерный массив из n×m элементов (N,М≤ 100) a11, a12 , ..., a1N ; am1, am2

, ..., amN.. Найти сумму элементов на нечетных местах массива и произведение элементов на четных местах массива.

Читайте также

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.

На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

Помогите написать программу в паскале!Очень надо!

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игро

к может добавить в кучу два камня или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 17 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 25. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 25 или больше камней.
В начальный момент в куче было S камней, 1 ≤ S ≤ 24.
1. При каких S: 1а) Петя выигрывает первым ходом; 1б) Ваня выигрывает первым ходом?
2. Назовите три значения S, при которых Петя может выиграть своим вторым ходом?
3. При каком S Ваня выигрывает своим первым или вторым ходом?



Вы находитесь на странице вопроса "4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.