Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ИНФОРМАТИКА!!!

10-11 класс

Написать программу определения числа билетов с 6-значными номерами,у которых сумма первых 3 десятичных цифр равна сумме 3 последних десятичных цифр (ПАСКАЛЬ)

анька1анька 13 апр. 2014 г., 5:48:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Roman5246
13 апр. 2014 г., 7:12:23 (10 лет назад)

Program BB;
uses crt;
Var s,a,b,v,z,i:longint;
Begin s:=1; {учитываем билет с номером 000000}
for i:=1 to 999999 do {перебираем билеты от 000001 до 999999}
begin   
v:=i;   
z:=0;   
while z<3 do  begin
z:=z+1;
a:=v mod 10 +a; v:=v div 10 end; {считаем сумму последних трех чисел}   
while z<6 do  begin z:=z+1;
b:=v mod 10 +b;
v:=v div 10
end; {считаем сумму первых трех чисел}   
if a=b then s:=s+1;   
a:=0;   
b:=0;
end;
writeln(s);
ReadKey;
end.

Ответить

Другие вопросы из категории

Определите,какое число будет напечатано в результате работы следующей программы

Алгоритмический язык
нач
цел а, b
a :=56
b :=a-70
нц пока не (b>0)
b :=b+13
кц
нц пока mod(a,b)<>0
a :=a-4
кц
вывод а
кон

помогите срочно надо!!!

1. Что такое право пользования?
2. Какие юридические документы составляют нормативно-правовую основу мер по защите авторских прав?

Var x,y:integer;

function nod(x:integer):Longint;
begin
if x=0 then nod:=1
else nod:=nod(x-1)*x

поясните последние две строчки плз

Напишите программу, которая в последовательности натуральных

чисел определяет сумму чисел, кратных 3. Программа получает на
вход количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 3.
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести одно число – сумму чисел, кратных 3.

Читайте также

Здравствуйте, хочу поступить в университет, но на то направление что я хочу поступить просят (по выбору университета) информатику или физику, я выбрал

один и готовился к физике, но потом я увидел университет другой и там прося информатику, пожалуйста подскажите из вашего опыта или опыта знакомых, сколько нужно примерно времени для того чтобы подготовиться к сдаче ЕГЭ по информатике с азов, возможно ли за пол года? при условии что я хорошо знаю математику.

Здравствуйте, хочу поступить в университет, но на то направление что я хочу поступить просят (по выбору университета) информатику или физику, я выбрал

один и готовился к физике, но потом я увидел университет другой и там прося информатику, пожалуйста подскажите из вашего опыта или опыта знакомых, сколько нужно примерно времени для того чтобы подготовиться к сдаче ЕГЭ по информатике с азов? при условии что я хорошо знаю математику.
Пожалуйста отвечайте конкретнее, из личного опыта или из опыта знакомых.

помогите с информатикой,пожалуйста)

Нужно записать фрагмент программного кода,который получает слово романтика из слова информатика и выводит результат на экран

ЕИЭЯ под номером 250.

Информатика. Не мне, другу помочь.
Хееелп.



Вы находитесь на странице вопроса "ИНФОРМАТИКА!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.