Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу для решения задачи. С2.Даны целые числа a,b,с.Если а≤b≤c,то все числа замените квадратами,если а>b>c,то каждое число замените

5-9 класс

наибольшим из них,в противном случае смените знак каждого числа. С2.По номеру месяца выдайте квартал,которому он принадлежит.

Viptsoba 14 сент. 2015 г., 9:22:09 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Slowwwy
14 сент. 2015 г., 10:04:21 (8 лет назад)

var a,b,c:integer;
begin
readln(a,b,c);
if (a<=b) and (b<=c) then
begin
a:=a*a;
b:=b*b;
c:=c*c;
end
else if (a>b) and (b>c) then
begin
if a<b then a:=b;
if a<c then a:=c;
b:=a; c:=a;
end 
else     
begin       
a:=a*(-1);       
b:=b*(-1);       
c:=c*(-1)     
end; 
writeln(a:4, b:4, c:4);
end.

Ответить

Другие вопросы из категории

помогите пожалуйста. срочно нужно ! Разработать программу для подсчета количества отрицательных чисел среди целых чисел a, b, c. Программа

должна иметь дружественный интерфейс. Протестировать программу для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3).

Помогите составить быстрее и правильно пожалуйста массиве А(20),заполненном случайными числами в диапазоне (-50:+50) поменять

местами наибольше элемент с наименьшим.Распечатать полученный

1.Расположите в порядок возрастания единицы измерения инфомации.

1 байт 2 мегабайт 3 бит 4 терабайт 5 килобайт
2.Сколько информации содержится в слове ИНФОРМАТИКА, если в каждом символе 1 байт информации?
1. 11бит 2. 1024бита 3. 88бит 4. 10 байт
3.Сравните (вставьте знаки < > =)
1024кб 10000бит
2мб 2000байт
128бит 16 байт
1кб 8192бита
4.Запишите десятичные числа 251 и 77 в двоичной системе счисления(привести решение).

Ребят, срочно нужна помощь.

Не могу вспомнить игру, в которую играем на информатике, помню,что вроде на T начинается. В самой игре там замок есть, и дракон какой-то заперт, нужно всякие разные задания проходить. на логику и прочие. кто помнит ,скажите,пожалуйста. и,если можно скиньте ссылку на скачивание игры

Читайте также

напишите программу для решение задачи . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей , округля я

значение скорости до целых чисел . необходимо определить минимальную зарегистрированную скорость автомобиля . если скорость хотя бы одного автомобиля была больше 80 км/ч , ВЫВЕДИТЕ YES ИНАЧЕ NO . программа получает на вход число проехавших автомобилей n(1<=n<=30), затем указываются их скорости . значение скорости не может быть меньше 1 и больше 300 . программа должна сначала вывести минимальную скорость , затем yes или no .

1)Составить алгоритм для решения задачи: Вычислить угол между двумя векторами, если эти векторы заданы своими координатами.2)Составить

алгоритм для решения задачи: Найти действительные корни квадратного уравнения вида ax^2+bx+c=0.

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округ

ляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км\ч, выведите YES, иначе выведите NO.

Программа получает на вход число проехавших автомобилей N (1=<N=<30), затем указывает их скорости. Значение скорости не может быть меньше 1 и больше 300.

Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать на языке Паскаль

Пример работы программы: (смотри во вложениях)

1.Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно.

2.Составить блок - схему кипячения чайника.

3.Составить алгоритм сбора яблок в саду.Ваша задача сводится к тому,что необходимо собрать ведро яблок с земли.

4.Составьте алгоритм на формальном языке и блок - схему для решения следущего примера : y=5x+6,если х=3



Вы находитесь на странице вопроса "Напишите программу для решения задачи. С2.Даны целые числа a,b,с.Если а≤b≤c,то все числа замените квадратами,если а&gt;b&gt;c,то каждое число замените", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.