Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

PASCAL

5-9 класс

Даны координаты трех точек. Вычислите периметр треугольника, используя функцию вычисления длины отрезка по координатам его вершин.

Kirillll12345678910 21 окт. 2015 г., 5:37:14 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ler4irk
21 окт. 2015 г., 6:47:58 (8 лет назад)

var x1,x2,x3,y1,y2,y3,p:real;
begin
writeln('Введите координаты 1 вершины через пробел');
readln(x1,y1);
writeln('Введите координаты 2 вершины через пробел');
readln(x2,y2);
writeln('Введите координаты 3 вершины через пробел');
readln(x3,y3);
p:=sqrt(sqr(x2-x1)+sqr(y2-y1))+sqrt(sqr(x3-x2)+sqr(y3-y2))+sqrt(sqr(x1-x3)+sqr(y1-y3));
writeln('Периметр треугольника равняется ',p);
end.

Ответить

Другие вопросы из категории

Срочно! написать программу в паскаль!

Вычислить значение функции y= (-x)* (-x)+3x+9
Где x принадлежит промежутку ( -5;3]

Напишите программу для решения задачи. С2.Даны целые числа a,b,с.Если а≤b≤c,то все числа замените квадратами,если а>b>c,то каждое число замените

наибольшим из них,в противном случае смените знак каждого числа. С2.По номеру месяца выдайте квартал,которому он принадлежит.

помогите пожалуйста. срочно нужно ! Разработать программу для подсчета количества отрицательных чисел среди целых чисел a, b, c. Программа

должна иметь дружественный интерфейс. Протестировать программу для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3).

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "PASCAL", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.