Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел

5-9 класс

( сейчас прошли циклические алгоритмы, нужна и блок-схема)

5925839 02 мая 2014 г., 7:08:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Falaleeva2000
02 мая 2014 г., 8:47:02 (10 лет назад)

var n,a,i:integer;
s:longint;
begin
writeln('введите количество чисел');
readln(n);
a:=0; s:=0;
writeln('введите числа');
for i:=1 to n do begin
readln(a);
if a>10 then s:=s+a*a;
end;
if s=0 then writeln('положительных чисел нет') else writeln(s);
end.

+ 0 -
Аврора1999
02 мая 2014 г., 10:31:54 (10 лет назад)

а массивы вы проходили?

Ответить

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.