Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Cоздать программу в паскале "ОБРАБОТКА ОДНОМЕРНЫХ МАССИВОВ" плиз очень надо

10-11 класс

саид11 18 окт. 2016 г., 9:17:20 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nurbala
18 окт. 2016 г., 12:17:20 (7 лет назад)

Program asd;
USES crt;
Const n=5;
var   A:array[1..n] of integer; 
   i,j,k:integer;
BEGIN
  for i:=1 to n do
  begin 
 A[i]:=random(10);
 Write(A[i]:4);   
  end;
 for i:=1 to n-1 do
 begin 
  for j := 1 to n-i do 
  if A[j]>A[j+1] then 
  begin 
k:=A[j]; 
A[j]:=A[j+1];
A[j+1]:=k 
 end;           
 end;           
Writeln;
Writeln ('Отсортированный массив по возрастанию: ');
  for i := 1 to n do 
    Write (A[i]:4); 
  Writeln;
END.

+ 0 -
Qwertyuij
18 окт. 2016 г., 13:25:46 (7 лет назад)

Не понял, это просто сложить их, разделить и т.д. ?!

+ 0 -
Lapkina2001
18 окт. 2016 г., 14:17:23 (7 лет назад)

Условие не точное, обработок много, можно найти и минимальное число и заменить его наибольшим

+ 0 -
Chubinska
18 окт. 2016 г., 16:19:12 (7 лет назад)

может "сортировка одномерных массивов"?

+ 0 -
Sharapova2002
18 окт. 2016 г., 17:39:58 (7 лет назад)

Давайте сортировку сделаю

Ответить

Другие вопросы из категории

Помогите пожалуйста.

1. Составить проект для исполнителя "Рыжий кот", выполнив который, он нарисует прямоугольник со сторонами 100 и 50, и квадрат со стороной 75. Соседние стороны прямоугольника должны быть разного цвета, а противоположные - одинакового. Цвет сторон квадрата должен отличаться от цветов сторон прямоугольника. Квадрат и прямоугольник не должны пересекаться.

2. Составить проект, в котором исполнитель изменяет костюмы из папки Fantasy. Составьте сценарий этого проекта. Используйте звук, которые соответствуют выбранным вами костюмам.

ПОМОГИТЕ РЕШИТЬ 1, ОЧЕНЬ НАДО ПОЖАЛУЙСТА

Читайте также

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "Cоздать программу в паскале "ОБРАБОТКА ОДНОМЕРНЫХ МАССИВОВ" плиз очень надо", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.