Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

"ГНЧЭ-1" – сложное электронное устройство, выдающее каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду

10-11 класс

дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства.


Формат входного файла

Дано количество секунд (от 1 до 1000000), которые работает генератор после включения.


Формат выходного файла

Результат работы генератора

Robertkgd 08 июня 2013 г., 16:41:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krististupina
08 июня 2013 г., 18:51:21 (10 лет назад)

Имхо так:

 

Program solution;
Uses Crt;
Var sec, num, n1, i : Longint;

Begin
ClrScr;
Readln(sec);
num := 1;
n1 := 0;

repeat
        for i := 1 to num do
                begin
                write(num, ' ');
                n1 := n1 + 1;
                if n1 >= sec then break;
                end;
        num := num + 1;
until n1 >= sec;
End.

Ответить

Другие вопросы из категории

Даны величины переменных A,B,C,D. Требуется перенести значения переменных, следующим образом: в D сумму значений переменных С и В, в переменную А

поместить значение из В, в В значение из С, в С значение из D решение в паскале

как надо смотреть на монитор?

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)

обычный дорожный светофор без дополнительных секцийподает 6 видов сигналов(непрерывные красный,желтый и зеленый,мигабщие желтый и зеленый,красный и

желтый одновременно) Электронное устройство управления светофором последовательно воспроизводит записанные сигналы. Подряд записано 100 сигналов светофора. В байтах данный информационный объем состовляет. (условие некорректно,имеется в виду количесво целых байтов)



Вы находитесь на странице вопроса ""ГНЧЭ-1" – сложное электронное устройство, выдающее каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.