Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В массиве, содержащем 15 элементов, найти сумму элементов, абсолютная величинакоторых отличается от заданного числа более чем на 6. Среди остальных

10-11 класс

элементовнайти минимальный элемент и его индекс.

Vlad8kmv 22 дек. 2013 г., 6:38:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TEDI150922
22 дек. 2013 г., 7:45:32 (10 лет назад)

uses crt;
const n=15;
var
a: array [1..n] of integer;
sum,min,i,x,j: integer;
begin
clrscr;
sum:=0;
min:=0;
write ('Array: ');
for i:=1 to n do
begin
a[i]:=random(41)-20;
write (a[i],' ');
end;
writeln ();
write ('x=');
readln (x);
for i:=1 to n do
begin
if abs(a[i])=x then
sum:=sum+a[i]
else
if min>a[i] then
begin
min:=a[i];
j:=i;
end;
end;
writeln ('sum=',sum);
writeln ('min=',min);
writeln ('index=',j);
readln ();
end.

+ 0 -
пасейдон
22 дек. 2013 г., 9:48:33 (10 лет назад)

язык?

+ 0 -
СергейЛазука
22 дек. 2013 г., 12:37:44 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Читайте также

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.

Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных

элементов; 3) сумму элементов которые делятся на 3; 4) минимальный и максимальный элемент. (используя procedure или function, но чтоб была рекурсия)ПОЖАЛУЙСТА ПОМОГИТЕ ВОПРОС ЖИЗНИ И СМЕРТИ!!

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел. получите новый массив, каждый элемент которого равен квадрату

соответствующего элемента исходного массива. в полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива. выведите на экран исходные и полученные результаты



Вы находитесь на странице вопроса "В массиве, содержащем 15 элементов, найти сумму элементов, абсолютная величинакоторых отличается от заданного числа более чем на 6. Среди остальных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.