Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Переведите вещественное число 150,5 в машинное представление с плавающей точкой (тип Single).

10-11 класс

Katyini 11 февр. 2016 г., 19:30:00 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Красотка48
11 февр. 2016 г., 21:22:10 (8 лет назад)

150.5_{10}=10010110.1_{2}
10010110.1_{2}=1.00101101_{2}*2^{7}

Ответить

Другие вопросы из категории

Задача 7. Найти первый и последний элементы массива, кратные

числу 3.
Пример: массив 7 2 6 5 4 4 10 3 9
элементы, кратные 3 6 39
первый и последний из них 6 9

Установите соответствие между поколениями ЭВМ и основными составляющими элементарной базы.

1) 1-е поколение а) БИС, СБИС
2) 2-е поколение б) Электронные лампы
3) 3-е поколение в) Микросхемы
4) 4-е поколение г) Транзисторы

Элементной базой ЭВМ третьего поколения служили:

А) электронные лампы;
Б) полупроводниковые элементы;
В) интегральные схемы;
Г) большие интегральные схемы;
Д) сверхбольшие интегральные схемы.

Читайте также

Напишите программу, которая

позволяет ввести три вещественных числа и выводит на экран:


разность
целых частей первого и второго чисел;
косинус
удвоенного произведения первого на третье;
сумму
квадратов синуса второго числа и косинуса третьего.


Все вещественные числа должны
быть выведены в форме с фиксированной точкой с двумя знаками после запятой;
перед каждым вычисленным значением должны идти пояснительный текст и выражение.

1. Переведите числа в десятичную систему счисления

a. 11010,112;
b. 534,078;
c. А06,F16;
2. Переведите числа в двоичную систему счисления
a. 534,078;
b. А06,F16;
3. Переведите двоичное число 110000101,1 в восьмеричную и
шестнадцатеричную системы счисления

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Программирование. Даны три вещественных числа a,b,c. Существует ли треугольник со сторонами a,b,c? program dz1; uses crt; var

a,b,c:integer;

begin

writeln('введите три числа: ');

readln(a,b,c)

а дальше не знаю помогите пожалуйста!!!!)

Переведите десятичное число 9233 в двоичное, восьмеричное и шестнадцатеричное. Для проверки правильности перевода числа, выполните обратную операцию, т.е.

пе-реведите полученное двоичное, восьмеричное и шестнадцатеричное число в десятичное



Вы находитесь на странице вопроса "Переведите вещественное число 150,5 в машинное представление с плавающей точкой (тип Single).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.