Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3,… Разработать схему алгоритма для вычисления числа Фибоначчи. Определить f1

5-9 класс

0, f25, f40.

АФанасьевД 06 июня 2013 г., 7:46:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Koteechka90
06 июня 2013 г., 9:17:02 (10 лет назад)

Ето прога на Pascal!(Будут вопросы пиши) 

 

program fibonachi;
var f:array [0..1000] of longint;
a,i,i2,i3:integer;
begin
writeln ('Vvedit nomer potribnogo chisla');
readln (a);
f[1]:=1;
f[0]:=1;
if a<=1 then
writeln(f[a]);
if a=2 then writeln(3);
if a>2 then begin
for i:=2 to a do
begin
i2:=i-1; i3:=i-2;
f[i]:= f[i2]+f[i3];
end;
writeln (f[i]); end;
readln
end. 

 

f10=89

f25=121393

f40 =165580141

Ответить

Другие вопросы из категории

Читайте также

срочно подскажите мне!!!!

Дано целое число А. Если значение А > 0, то необходимо
увеличить его на единицу. Разработать схему алгоритма для решения этой
задачи. Протестировать алгоритм для A=5, A=-4, A=0. сделать в паскале.


Программу я написала:

Program n1;
var A: real;
begin
readln (a);
if a>0
then a:=a+1;
writeln;
end.


правильно или нет? и какие у меня должны выходить значения?

ПОМОГИТЕ, ПОЖАЛУЙСТА!!!!!!

Даны два действительных числа Х и У. Если Х > У, то вычислить произведение этих чисел, иначе их сумму. Разработать схему алгоритма для решения этой задачи( Нужно решить через Паскаль с ветвящейся структурой).

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!! СРОЧНО НАДО !!!

Разработать схему алгоритма для ввода четырех целых чисел и вычисления их среднего арифметического. Протестировать алгоритм на различных исходных данных( включая вещественные числа) и доказать правильность его работы.

Числа Фибоначчи строятся следующим образом: 1, 1, 2, 3, 5, …. В этой последовательности, начиная с третьего числа, каждый следующий член равен сумме двух

предыдущих. Получаем, что, например, шестое число равно 8, а десятое - 55.

Требуется написать программу, которая определяет, является ли заданное число числом Фибоначчи.



Вы находитесь на странице вопроса "Числа Фибоначчи (fn) определяются формулами: f0=f1=1, fn=fn-1+fn-2 при n=2,3,… Разработать схему алгоритма для вычисления числа Фибоначчи. Определить f1", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.