Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Работа в паскале.

5-9 класс

Даны три переменные: x, y, z. Если их значения делятся без остатка на 4, то удвоить их; в противном случае заменить значение переменной на противоположное.

BlackLotusRf 27 дек. 2013 г., 7:48:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1997rus
27 дек. 2013 г., 10:04:28 (10 лет назад)

var x,y,z:integer;
begin
write('Введите x, y, z: ');
readln(x,y,z);
if (x mod 4=0) and (y mod 4=0) and (z mod 4=0) then
      begin
      x:=x*2;     
      y:=y*2;
      z:=z*2
      end
      else
         begin
         x:=-x;
         y:=-y;
         z:=-z
         end;
writeln(x,' ',y,' ',z)
end.

Ответить

Другие вопросы из категории

НАПИСАТЬ ПРОГРАММУ В КУМИРЕ.

Числовой ряд из 10 чисел задается
генератором случайных чисел в диапазоне от 1 до 20. Найти сумму чисел,кратных 4

Оперативная память 16Кбайт. Сколько страниц текста можно было бы разместить в памяти этого компьютера, если на странице размещается 40 строк по 60

символов в каждой строке, а для храниния одного символа требуется 8 битов.

Заранее спасибо!

перевисти в 10 с/с 111011

Читайте также

Даю много баллов!ПАСКАЛЬ!Только решите!С подробной записью всей программы и ответом!Даны 2 массива А и В по 20 элементов.Сформировать массив с=А+В,в

полученном массиве найти сумму элементов,имеющих чётный индекс.Запишите подробно всю прграмму...Прошу.Работаем с Паскалем(((

ДАЮ 25 БАЛЛОВ!!!!!

Работа с Паскалем.
Найти минимальное и максимальное значение из четных чисел и записать их в файл output.txt

Информатика, 9 класс, работа в паскале, помогите!!!

Написать программу, которая выводит на экран сообщение, в какую четверть координатной плоскости попала точка с заданными координатами. Координаты точки вводятся с клавиатуры.
Например, для Х=4, Y=6 она должна ввести "Точка лежит в 1 четверти".



Вы находитесь на странице вопроса "Работа в паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.