Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Решите задачи: 1) Введите элементы массива а[1..10] с клавиатуры и вычислите количество элементов с четными положительными значениями. 2)

10-11 класс

Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы, значения которых больше 5 и меньше 15.

заранее спасибо за решение.

Reflex618651 11 июня 2015 г., 15:05:14 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jexx
11 июня 2015 г., 16:33:46 (8 лет назад)

1)
program test;
uses crt;
var
  arr:array[1..10] of integer;
  i,cou:integer;
begin
clrscr;
  for i:=1 to 10 do
  begin
    write('Itput arr[',i,'] ');readln(arr[i]);
    if (arr[i]>0) and (arr[i] mod 2 = 0) then cou:=cou+1;
  end;
  writeln(cou);
end.

2)Тут вообще можно 1 циклом обойтись, но так не надо заворачиваться с перетаскиванием курсора.
program test;
uses crt;
var
  arr:array[1..10] of integer;
  i:integer;
begin
  randomize;
  clrscr;
  for i:=1 to 10 do
    begin
      arr[i]:=random(20)+1;
      write(arr[i],' ');
    end;
  writeln;
  for i:=1 to 10 do
    if (arr[i]>5) and (arr[i]<15) then write(arr[i],' ');
end.



Ответить

Другие вопросы из категории

СРОЧНО

Паскаль:
Вычислить S=3+5+7+...(2n+1)

Вычислить площадь поверхности шара План работы.1. Условия задачи.2. Математическая модель.3. Список переменных с их

расшифровкой.

4. Блок-схема алгоритма.

5. Программный код.


Какой объем видеопамяти необходим для хранения четырех страниц изображения при условии, что разрешающая способность дисплея 640*350 пикселей, а количество

используемых цветов равно 256?
A)1750 kb B)896 kb C)875 kb D)448 kb(килобайт)
пожалуйста очень срочно надо!!!!!! и подробно тоже!!!!

Читайте также

плохо очень знаю С++ оч надо решить задачи

1)дан одномерный массив заполнит его так чтобы получилась геометрическая прогрессия где первый член равен 2, d=-3 и вывести в столбец.
2)вывести массив в строку и найти минимальный элемент массива.
3)отсортируйте его по возрастанию и вычислите произведение элементов массива.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Программирование в VBA. Задача:Массив сотоит из двадцати элементов. Сколько элементов массива нужно сложить (начиная с первого), чтобы сумма превысила

число 100. Вот моя программа:

Private Sub CommandButton1_Click()
Dim C(1 To 20) As Integer
Dim I, N, S As Integer
For I = 1 To 20
C(I) = Cells(I, 1)
Next I
S = 0
N = 0
For I = 1 To 20
If S <= 100 Then S = S + C(I) And N = N + 1
Next I
Cells(2, 3) = "Количество элементов массива, сумма которых превышает 100=" & N
End Sub

как результат выводит "0" (т.е. N заданное изначально). Может, кто-то сможет подсказать ошибку? Это срочно!

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Напишите программу, которая подсчитывает

количество элементов массива равных макс. среди двухзначных чисел. Если ни одного такого числа нет, нужно вывести сообщение об этом.



Вы находитесь на странице вопроса "Решите задачи: 1) Введите элементы массива а[1..10] с клавиатуры и вычислите количество элементов с четными положительными значениями. 2)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.