Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать программу через repeat.

10-11 класс

Дано натуральное число n>10. найти первую цифру данного числа

Яна200219 07 окт. 2015 г., 5:42:53 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
танька2012
07 окт. 2015 г., 7:32:14 (8 лет назад)

 var n: integer;
begin
 readln(n);
 repeat 
 n:= n div 10;
 until n<10; 
 writeln(n); 
end.

Ответить

Другие вопросы из категории

Паучок соединил некоторые ветки паутинками как на рисунке. С одной ветки на другую можно попасть только по паутинке. Уберите некоторые из паутинок так,

чтобы общая длина оставшихся паутинок была минимальна, но с любой ветки паучок мог попасть на любую другую (возможно не напрямую). Какова общая длина оставшихся паутинок?

А)10 Б)12 В)13 Г)15



10 в минус 14 степени - это ?

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс



Вы находитесь на странице вопроса "Написать программу через repeat.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.