Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ввести a и b и вывести квадраты и кубы чисел от a до b

5-9 класс

Пример:
Введите границы интервала :
4 6
4 16 64
5 25 125
6 36 216

Dzonnyya 23 янв. 2017 г., 21:24:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
GS8304
23 янв. 2017 г., 22:39:14 (7 лет назад)

program name;//Имя программы
uses crt;//Запуск программы в консольном режиме НЕОБЯЗАТЕЛЬНО
var 
   a : Integer; 
b : Integer; 
i : Integer; 
c : Integer;
BEGIN //Начало программы 
write('Введите 1 число: ');  readln(a);//Ввод значения первого числа 
c := b-a-1;  write('Введите 2 число: '); 
readln(b);//Ввод значения второго числа 
writeln(a, ' ' , b); //Вывод двух чисел
  writeln(a, ' ' ,a*a,' ' , a*a*a); // Вывод 1 числа, квадрата, куба 
for i := 1 to b-a-1 do  
begin   
a := a + 1;   
writeln(a, ' ',a*a, ' ', a*a*a); // Вывод всех чисел от a до b 
end;         
writeln(b, ' ' ,b*b,' ' , b*b*b);// Вывод 2 числа, квадрата, куба 
ReadKey;  
end. //Конец программы

+ 0 -
Kamila00007
24 янв. 2017 г., 1:33:39 (7 лет назад)

var
a,b,i:integer;
begin
readln(a,b);
for i:= a to b do 
writeln(i:6,sqr(i):6,Power(i,3):6);
readln
end.

+ 0 -
сандуюлияjulia
24 янв. 2017 г., 4:23:51 (7 лет назад)

Basic\Paskal?

+ 0 -
Annkate1356
24 янв. 2017 г., 5:44:27 (7 лет назад)

Паскаль

Ответить

Другие вопросы из категории

Какую краткую форму записи оператора IF вы знаете?

Какую полную форму записи оператора IF вы знаете?
Как отобразить полную и краткую форму записи IF в блог-схеме?
Умоляю помогите с вопросами!)))

Читайте также

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных

данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

турбо паскаль:пожалуйста сделайте хоть часть.массивы: №1. Вычислить сумму 10 целых чисел. Для обозначения чисел введем имя

массива Х, элементы которого имеют индекс I. Сумму обозначим именем SUM.

Sum = x[1]+x[2]+ … + x[10]

№2. Вычислить сумму 15 чисел вещественного типа. Имя массива обозначается через А, элементы которого имеют индекс I. Сумму обозначим именем SUM.

Sum = А[1]+А[2]+ … + А[15]. Вывести на печать результаты в три столбика: 1 - индекс, 2 – значения элементов массива, 3 – сумму.

№3. Найти все четные по значению элементы массива из N целых чисел. Вывести на печать значения элементов массива и их индекс. Ввод элементов массива производится с клавиатуры.

№4.Найти все четные и нечетные по значению элементы массива из N целых чисел. Вывести на печать значения элементов массива и их индекс. Ввод элементов массива производится с клавиатуры.графика:

1) Нарисовать закрашенный прямоугольник, окружность, линию, точку, прямоугольник, треугольник.

2) Нарисовать цепочку из окружностей одного цвета по горизонтали.

3) Нарисовать цепочку из окружностей одного цвета по вертикали.

4) Нарисовать цепочку из окружностей одного цвета по диагонали.

5) Нарисовать цепочки из окружностей зеленого цвета - по горизонтали, красного цвета - по вертикали и желтого цвета - по диагонали.

6) Нарисовать светильник, уличный фонарь.

7) Составьте программу, выводящую на экран компьютера следующие фигуры:

цветка; снеговика; елки; изображение какого-либо животного;

автомобиля.оператор выббора:

№1. Определить по номеру месяца соответствующее время года.

№2. Ввести номер дня недели и вывести соответствующий ему день недели на русском и английском языках. В противном случае вывести сообщение «Такого номера дня недели не существует».

№3. В случае выполнения выражения 2х+1, необходимо соответственно константам выполнить следующие действия (операторы):

5 вычислить выражение ;

11 вычислить выражение ;

15 k1 должно быть равно целочисленному делению х на 2 (деление нацело);

17 k3 должно быть равно сумме двух операций (х div 3) и ( х mod 3);

19 k2 должно быть равно целому остатку от деления х на 2;

21 вывести строчку из последовательности звездочек *;

23 значению d1 должна соответствовать проверка числовой величины х на четность;

В случае если операции не выполнятся, вывести на экран сообщение: «Приносим извинения, Ваши вводимые данные для работы оператора не подходят, попробуйте ввести следующие числа: 2, 5, 7, 8, 9, 10, 11».

№4. Составить программу для выбора действий из сказки: «Направо пойдешь – коня потеряешь, налево пойдешь – смертью умрешь, прямо пойдешь – друга найдешь». Использовать символьный тип данных.

№5. Группу детей, приезжающую в лагерь для отдыха, распределяют по отрядам:

С 6 до 7 лет – 5 отряд;

С 7 до 9 лет – 4 отряд;

С 9 до 11 лет – 3 отряд;

С 11 до 13 лет – 2 отряд;

С 13 до 15 лет (включительно) – 1 отряд;

Составить программу, которая позволяла бы каждому приезжающему самому определить свой отряд. В лагере имеется персональный компьютер.символьные данные:

№1. Составить программу, которая выведет на экран все прописные буквы латинского алфавита от A до Z в одну строчку.

№2. Вывести на печать все прописные и строчные буквы латинского алфавита от A до Z (от a до z ) в 2 строчки.

№3. Вывести на печать все прописные и строчные буквы латинского алфавита от A до Z (от a до z ) и все прописные и строчные буквы русского алфавита от А до Я (от а до я).

1 строка символов должна быть красного цвета, 2 строка символов - зеленого цвета, 3 строка символов - желтого цвета, 4 строка символов - синего цвета.

№4.Вывести на печать все прописные и строчные буквы латинского и русского алфавитов в обратном порядке с использованием цветовой гаммы для символов.оператор цикла:

1) Вычислить А=А+2, N=N+1, при условии 2A£3N+1. Цикл начинает вычисление выражений со значений

А=1, N=1. (Оператор цикла с предусловием)

2) Вычислить Y=X2, при X=8,6,4,2. (Оператор цикла с послеусловием)

3) Вычислить A=2I, B=2I+1. Параметр I изменяется от 1 до 5.

(Оператор цикла с параметром)

4) Вычислить A=2I, B=2I+2. Параметр цикла I изменяется от 5 до 1.

(Оператор цикла с параметром)

5) Составить программу, которая выводит автоматически квадраты целых чисел от 1 до 10.

(Оператор цикла с предусловием)

6) Вычислить Y=X3, где Х изменяется от 1 до 10

(Оператор цикла с послеусловием).

7) Вычислить выражения Y= X2+1, Z=, Х от 1 до 10.

(Оператор цикла с параметром)

8) Составить программу, которая выводит квадраты вводимых чисел во время выполнения программы до тех пор, пока введенное число не станет больше либо равно 10. (Оператор цикла с предусловием)

9) Составить программу для вычисления суммы квадратов чисел от 1, 2, 3, …, 15.

(Оператор цикла с параметром)

10) Составить программу, которая выводит на экран таблицу умножения от 2 до 9. (Сложные циклы)

11) Составить программу, которая выводит на экран таблицу умножения для вводимых в произвольной форме чисел от 1 до 10. (Сложные циклы)

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "Ввести a и b и вывести квадраты и кубы чисел от a до b", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.