Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать программу Заполнить массив из 15 элементов случайными числами (-20;80) Посчитать сумму всех элементов массива Посчитать количество отрицательных

5-9 класс

элементов

Olyaolga111 20 нояб. 2015 г., 1:34:20 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Кексики
20 нояб. 2015 г., 3:48:48 (8 лет назад)

const

  n = 15;

var

  a:array[1..n] of integer;

  i, Count, Summ:integer;

begin

  randomize;

  Count := 0;

  Summ := 0;

  for i := 1 to n do

  begin

    a[i] := random(101) - 20;

    write(a[i], ' ');

    inc(Summ, a[i]);

    if a[i] < 0 then

      inc(count);

  end;

  writeln;

  writeln('Summ = ', Summ);

  writeln('Count = ', count);

  readln;

end.

Ответить

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

помогите пожалуйста составить программу

Заполнить массив из 500 элементов случайными числами в интервале [0..100]. Отсортировать его по возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» . Вывести на экран число перестановок элементов массива в том и в другом случае. Массив выводить на экран не нужно.



Вы находитесь на странице вопроса "Написать программу Заполнить массив из 15 элементов случайными числами (-20;80) Посчитать сумму всех элементов массива Посчитать количество отрицательных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.