Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите решить, пожалуйста!

10-11 класс

Даны стороны трёх треугольников. Найдите сумму их периметров. Определите процедуру для расчёта периметра треугольника.
Написать программу для Pascal. Задача с использованием подпрограмм-процедур.

ученик186 29 апр. 2013 г., 14:06:51 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lizyxa98
29 апр. 2013 г., 15:41:06 (11 лет назад)

procedure Calc(const a,b,c: real; var p: real);
begin
  p := a + b + c;
end;


var a, b, c, p: real;
begin
  readln(a);
  readln(b);
  readln(c);
  Calc(a, b, c, p);
  writeln(p);
end.

Ответить

Другие вопросы из категории

Определите значение переменной спосле выполнения следующего фрагмента программы:

a := 56;
b := 2;
k := 5;
a := a/8 – b;
if a > b then
c := 10*a – k*b
else
c := 10*a + k*b;

однажды один программист поместил объявление о продаже устройства вывода информации звуковой информации,однако по случайности перепутал и я в объявлении

было забавно написано о продаже маленькой собачки,декоративной породы.разрешите путаницу и напишите,что же хотел выставить на продажу невнимательный программист.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

помогите решить пожалуйста))


Вы находитесь на странице вопроса "Помогите решить, пожалуйста!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.