Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

напишите прогу, где осуществляется ввод целых чисел,(ввод осуществляется до тех пор, пока не будет введен 0) и ПОДСЧЕТ кол-ва положительных и

5-9 класс

отрицательных чисел

Ilvirka2004 13 июля 2016 г., 13:37:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Takoka
13 июля 2016 г., 16:11:51 (7 лет назад)

program qq;
var a,pol,otr:integer;
begin
pol:=0;
otr:=0;
repeat
begin
writeln('Введите число');
read(a);
if a>0 then pol:=pol+1
else otr:=otr+1;
end;
until a=0;
writeln('Положительных чисел - ',pol);
writeln('Отрицательных чисел - ',otr);
end.

Ответить

Другие вопросы из категории

Определить, делиться ли целое число на 6, если "да", то возвести его в квадрат.

|Pascal ABC|
(Алгоритмическая конструкция ВЕТВЛЕНИЕ; Принятие решений в программе; Полная и сокращенная формы условного оператора; Составной оператор и т.д.

Читайте также

ПОМОГИТЕ НАПИСАТЬ ХОТЯ БЫ ОДНУ ЗАДАЧУ НА Pascal ОНИ НЕ СЛОЖНЫЕ , А Я ДАЮ МНОГО ПУНКТОВ!! За 2 лучший ответ! Без плагиата! 1.Написать

программу,используя оператор цикла While,которая будет вводить целые положительные числа не превышающие 100. Найти сумму квадратов чисел 2.Написать программу используя оператор цикла Repeat,которая будет вводить целые числа до тех пор пока не будет введён 0.Подсчитать среднее арифметическое введённых чисел.

Помогите с задачей.

Вводится последовательность целых чисел, до тех пор пока не введено число n
Найти сумму положительных среди них?

Цикл с пост условием!! помогите

Написать программу которая будет вводить целые числа до тех пор пока не будетвведён 0. Подсчитать количество положительных и отрицательных чисел.



Вы находитесь на странице вопроса "напишите прогу, где осуществляется ввод целых чисел,(ввод осуществляется до тех пор, пока не будет введен 0) и ПОДСЧЕТ кол-ва положительных и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.