Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Определить, делиться ли целое число на 6, если "да", то возвести его в квадрат.

5-9 класс

|Pascal ABC|
(Алгоритмическая конструкция ВЕТВЛЕНИЕ; Принятие решений в программе; Полная и сокращенная формы условного оператора; Составной оператор и т.д.

МаркТимофеев 11 июля 2016 г., 1:42:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
павшая99
11 июля 2016 г., 2:55:42 (7 лет назад)

var  x:integer;
begin 
write('Введите число: '); 
readln(x); 
if x mod 6=0 then  writeln(sqr(x))
end.

Ответить

Другие вопросы из категории

Домашнее задание:Решить задачи:Задаются два разных по величине числа. Определить какое из этих чисел больше. (Сравнение двух чисел)Даны два числа. Ес

ли квадратный корень из второго числа меньше первого числа, то увеличит второе число в пять раз.

Читайте также

Определить, делится ли первое число на другое без остатка.

Сначала строим информационную модель устно.

Во-первых, вводятся числа А и В.

Находим остаток от деления числа А на число В.

Если остаток от деления равен нулшю, то выводим результат: Число А делится на число В без остатка

Иначе

Результат – Число А делится на число В с остатком.

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни



Вы находитесь на странице вопроса "Определить, делиться ли целое число на 6, если "да", то возвести его в квадрат.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.