Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ВВЕСТИ 2 ЦЕЛЫХ ЧИСЛА .ОПРЕДЕЛИТЬ ДЕЛИТСЯ ЛИ 1 ЧИСЛО НА 2(ДА ДЕЛИТСЯ)(НЕТ НЕ ДЕЛИТСЯ)

5-9 класс

Mila0525 02 мая 2014 г., 23:04:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Колоскова
02 мая 2014 г., 23:46:39 (10 лет назад)

куда уж проще то

var a,b:integer;
begin
readln(a,b);
if(a mod b = 0)then writeln('Делится') else writeln('Не делится');
end.

+ 0 -
Sergey20041
03 мая 2014 г., 0:32:13 (10 лет назад)

действительно)

uses crt;
var x,y:integer;
begin
  read(x,y);
  if (x mod y=0) or (y mod x=0) then writeln('Делится')
    else writeln('Не делится');
end.

Ответить

Другие вопросы из категории

помогите составить программу.!

пользователь вводит любое число . программа должна вывести ответ положительное или отрицательное

Самолёт находится на высоте 5000 метров.

Обнаружилась неисправность работы двигателя. Самолёт начал падать. Бортовой
компьютер производит диагностику неисправности и сообщает пилоту о необходимых
действиях. Для решения этой задачи ему нужно выполнить 108 вычислительных
операций. Быстродействие компьютера – 1 млн. операций в секунду.
Успеет ли лётчик спасти самолёт, если минимальная высота, на которой самолёт
можно вывести из пике – 2000 метров?

Читайте также

Определить, делится ли первое число на другое без остатка.

Сначала строим информационную модель устно.

Во-первых, вводятся числа А и В.

Находим остаток от деления числа А на число В.

Если остаток от деления равен нулшю, то выводим результат: Число А делится на число В без остатка

Иначе

Результат – Число А делится на число В с остатком.

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

ПОМОГИТЕ В ЧЕМ ОШИБКА!!

program ZADACHA1;

var
a,b,c,d,d1,e:integer;
x,y,k,l:real;

begin
WRITELN('Цыбулак Максим');
READLN(a);
READLN(b);
c:=a+b;
e:=a*b;
d:=a-b;
k:=a/b;
d1:=b-a;
l:=b/a;
WRITELN('a+b=',c);
WRITELN('a-b=',d);
WRITELN('b-a=',d1);
WRITELN('a*b=',e);
WRITELN('a/b=',k);
WRITELN('b/a=',l);
m;=SQR(a);
n;=SQR(b);
o;=SQRT(a);
p;=SQRT(b);
WRITELN('квадрат числа',a,'=',m);
WRITELN('квадрат числа',b,'=',n);
WRITELN('корень числа',a,'=',o);
WRITELN('корень числа',b,'=',p);
end.

1. Дано натуральное число n. Определить есть ли в нем цифра x. (x, n - вводятся с клавиатуры)

2. Напишите программу, которая вводит последовательность целых ненулевых чисел, признак окончания ввода - число 0. Выясните есть ли в ней хотя бы одна пара одинаковых "соседних" чисел. СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "ВВЕСТИ 2 ЦЕЛЫХ ЧИСЛА .ОПРЕДЕЛИТЬ ДЕЛИТСЯ ЛИ 1 ЧИСЛО НА 2(ДА ДЕЛИТСЯ)(НЕТ НЕ ДЕЛИТСЯ)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.