Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Выведите

5-9 класс

на печать все числа, меньшие 10000,
сумма цифр которых равна некоторому числу, вводимому с клавиатуры

Ms95reg 29 окт. 2014 г., 15:24:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Liga2004
29 окт. 2014 г., 18:22:58 (9 лет назад)

В паскале это выглядит так:
var n1,n,k,s:integer;
begin
writeln('input k');
readln(k);
for n:=1 to 10000 do
begin
s:=0;n1:=n;
while n1<>0 do 
begin  
s:=s+n1 mod 10;  n1:=n1 div 10;
 end;
if s=k then writeln(n:5);
end;
end. 

Ответить

Другие вопросы из категории

3) Представьте житейскую ситуацию. Вы прекрасно провели лето в чудном местечке и сделали достойные фотографии. Оформили слайд-шоу в редакторе презентаций

и сохранили документ. Размер документа примерно 10 Мбайт. Вам жутко хочется поделиться с товарищем, который живет в другом районе и с нетерпением жаждет просмотра фотографий.
Документ можно передать с вашего компьютера на другой двумя способами:А) сжать архиватором, передать архив по электронной почте, распаковать ; Б) передать по электронной почте без использования архиватора. Какой способ быстрее и насколько, если- средняя скорость передачи данных электронной почте связи составляет 218 бит в секунду,- объём сжатого архиватором документа равен 70% от исходного,- время, требуемое на сжатие документа, - 12 секунд, на распаковку - 2 секунды?Каким способом передать документ быстрее и на сколько?

решите пожалуйста задачи:* 1)в корзине лежит 12 шаров.Определить количество информации,содержащие в сообщение,о том что взяли один шар. 2)сообщение

содержит 1 кбайта информации и состоит из 2048 символов.определить количество символов в алфавите,с помощью которого написано сообщение.

Читайте также

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.
Формат выходных данных
Выведите ответ к задаче.

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ
Одно целое положительное число, не превышающее 1000. Одно целое положительное число, не превышающее 1000. ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число. На языке С

ПАСКАЛЬ!!! Заполните случайными числами в диапазоне от 1 до 5 два массива А [1..10] и B [1..10], затем выведите их на экран. Найдите те элементы

массивов, которые попарно совпадают (например, А[2] и В[2]) и выведите сведения о них. Если совпадений нет – следует проинформировать об этом пользователя.



Вы находитесь на странице вопроса "Выведите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.