Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

НАРОД, ОЧЕНЬ СРОЧНО НАДО!

5-9 класс

Если дано 3-значное число, то получить из него новое число, в котором цифры будут записаны в обратном порядке.

Marino44ka73 10 янв. 2017 г., 18:28:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
344445678910
10 янв. 2017 г., 19:55:10 (7 лет назад)

Pascal

var num, res: integer;
begin
  writeln ('');
  readln (num);
  res:=res + 100*(num mod 10);
  num:=num div 10;
  res:=res + 10 *(num mod 10);
  num:= num div 10;
  res:=res + num mod 10;
  num:= num div 10;
  writeln (res);
end.

Qbasic

CLS
INPUT "Введите число", а
b = a MOD 10
a = (a - (a MOD 10))/10
b = b + (a MOD 10)
a = (a - (a MOD 10))/10
b = b + (a MOD 10)
a = (a - (a MOD 10))/10
PRINT "Обратное: ", b
END




Ответить

Другие вопросы из категории

записать программу выведения натурального числа N (<=n<=9999) в его словесной записи.

Например n=2345 - две тысячи триста пятдесят четыре

Помогите пожалуйста! нужно решить задачу

Пусть небольшая книжка содержит 150 страниц, на каждой странице 60 символов, всего 40 строк. Найдите весь обьём информации

Читайте также

ЛЮЮДИ ОЧЕНЬ СРОЧНО НАДО!!!!Сладкоежка Пончик решил испечь на свой день рождения 3 торта: яблочный, ореховый и шоколадный. Для приготовления одного

яблочного торта требуется 200 г сливочного масла, 200 г муки, 2 яйца, 300 г сахара и 8 яблок. Для приготовления одного орехового торта требуется 200 г орехов, 400 г муки, 300 г сахара, 300 г сливочного масла и 3 яйца. На один шоколадный торт тратится 3 шоколадки, 2 яйца, 300 г муки, 200 г сливочного масла и 100 г сахара. Масло в Цветочном городе стоит 100 монет за кг, сахар – 20 монет за кг, яйца 20 монет за десяток, мука 30 монет за кг, орехи – 100 монет за кг, яблоки – 2 монеты за штуку, шоколадки – 10 монет за штуку.
Сколько будет стоить каждый торт? Сколько продуктов каждого вида Пончик должен купить и сколько это будет стоить? Сколько всего денег он должен взять с собой в магазин, отправляясь за продуктами?НАДО СОСТАВИТЬ ТАБЛИЦУ В MICROSOFT OFFICE EXCEL

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

РЕБЯТА ПОМОГИТЕ ПЛИЗ ОЧЕНЬ СРОЧНО НАДО

1) Несуществующий тип шин:
1. адресная
2. данных
3. управления
4. аварийная
2) Надежность ЭВМ измеряется
1. ремонтопригодностью ЭВМ
2. количеством отказавших деталей
3. внутренней частотой микропроцессора
4. средним временем наработки на отказ
3)Чтобы преобразовать заголовок в подзаголовок с помощью панели "Структура" необходимо выполнить команду:
1. вверх
2. вниз
3.понизить уровень
4. повысить уровень
4) Арифметико-логическое устройство предназначено для
1. кратковременного хранения, записи и выдачи информации
2. связи между процессором и основной памятью
3. выполнения всех арифметических и логических операций над числовой и символьной информацией
4. формирования и подачи во все блоки ЭВМ в нужные моменты времени определенных сигналов управления
5) НЕ является служебной программа...
1. Архивация данных
2. Назначенные задания
3. Дефрагментация диска
4. Файловый менеджер
6) Формула это:
1. адреса ячеек и знаки арифметических операций
2. буквы и цифры, обозначающие адреса ячеек и знаки арифметических операций
3. набор стандартных констант
4. связь между исходными и рассчитываемыми данными
7) Расстояние между парами шрифтов называется:
1. кернинг
2. трекинг
3. кегль
4. интерлиньяж
8) Память, предназначенная только для чтения:
1. кэш
2. оперативная
3. постоянная
4. регистровая
9) результатом перевода десятичного числа 7(10) в двоичную систему счисления является число
1. 111(2)
2. 11(2)
3. 1000(2)
4. 110(2)
10) периферийные устройства выполняют функцию...
1. ввод и выдачу информации
2. управляет работой ЭВМ по заданной программе
3. хранение информации
4. обработку информацию

Помогите решить очень срочно надо


Вы находитесь на странице вопроса "НАРОД, ОЧЕНЬ СРОЧНО НАДО!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.