Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти все тройки натуральных чисел x,y,z из интервала от 1 до 20 ,для которых выполняется равенство x*x*y=z*z

10-11 класс

малина85 04 дек. 2013 г., 13:28:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Spiderx8
04 дек. 2013 г., 16:08:44 (10 лет назад)

for(x = 0; x < 20; x++)
{
    for(y = 0; y < 20; y++)
    {
        for(z = 0; z < 20; z++)
        {
            if(x * x * y == z * z)
            {
                printf("%d %d %d", x, y, z);
            }
        }
    }
}

Ответить

Читайте также

№1 Вывести на экран квадраты чисел от 1 до n. №2 Вывести на экран таблицу умножения от 1 до 10

числа n.

№3

Вычислить значение факториала n!

№4

В диапазоне от 1 до n вывести все четные числа на экран.

№5

Найти количество чисел, которые делятся на 3 и 5, из диапазона от 1 до n.

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.



Вы находитесь на странице вопроса "найти все тройки натуральных чисел x,y,z из интервала от 1 до 20 ,для которых выполняется равенство x*x*y=z*z", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.