Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

помогите!!!!((((

10-11 класс

Определить значение переменной y после выполнения следующих элементов программы:
x:=0;
y:=5;
repeat
y:=2*y;
x:=x+y
until y>5;

Sashenka11 19 авг. 2016 г., 23:28:00 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Popkovacawa
20 авг. 2016 г., 0:56:43 (7 лет назад)

Вначале переменным X и присваивается значения 0 и 5, соответственно.
Затем программа повторяет цикл с постусловием до тех пор, пока переменная Y не станет больше ⇒ всего один повтор

Y=2*Y=5*2=10
X=X+Y=0+10=10

Таким образом ответ
Y = 10

Ответить

Другие вопросы из категории

пожалуйста помогите переставить 3 и 5 столбец и 3 и 5 строку в массиве ...вроде правильно написала но выходит ошибка

program mas55;
const n=5;
type st=array[1..n] of real;
var i,j,d:integer;
b:st;
a:array[1..n] of st;
begin
for i:=1 to n do
for j:=1 to n do if j=3 then a[i,j]:=sqr(i)*j else a[i,j]:=2;
for i:=1 to n do
begin
for j:=1 to n do write (a[i,j]:6);
writeln
end;
writeln;
b:=a[3];
a[3]:=a[4];
a[4]:=b;
for i:=1 to n do
begin
for j:=1 to n do write (a[i,j]:6);
writeln;
for i:=1 to n do
begin
d:=a[i,3];
a[i,3]:=a[i,5];
a[i,5]:=d
end;
for i:=1 to n do
begin
for j:=1 to n do write (a[i,j]:6);
writeln
end;
writeln
end
end.

Даны числа А,В, и С .

Меньшее из них заменить полусуммой двух других

Нужно составить программку на Паскале.

Задача: Составить программу, которая подсчитывает количество цифр(символов) перед и после запятой. То есть, например, дано число 325,43
Программа должна выдать:
3, а затем, 2

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Задания за 9 класс. Ребят, помогите, пожалуйста. С Exel работать надо, на компьютере его нет (на windows 8 перешла), к тому же, честно говоря, не умею им

пользоваться. Добрые люди, пожалуйста, помогите :с Завтра сдавать :с



Вы находитесь на странице вопроса "помогите!!!!((((", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.