Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны числа А,В, и С .

10-11 класс

Меньшее из них заменить полусуммой двух других

Ksenyabogatova 15 июля 2016 г., 3:32:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Token1
15 июля 2016 г., 6:30:25 (7 лет назад)

var
  a, b, c: real;

begin
  readln(a, b, c);
  if (min(a, min(b, c)) = a) then
    a := (b + c) / 2
  else
    if (min(a, min(b, c)) = b) then
      b := (a + c) / 2
    else
      if (min(a, min(b, c)) = c) then
        c := (b + a) / 2;
  writeln(a, ' ', b, ' ', c);
end.

Ответить

Другие вопросы из категории

Нужно составить программку на Паскале.

Задача: Составить программу, которая подсчитывает количество цифр(символов) перед и после запятой. То есть, например, дано число 325,43
Программа должна выдать:
3, а затем, 2

Если в слове А отбросить первые две буквы, то получится слово В. Если в слове В заменить одну согласную букву на другую, то получится слово С. А и В -

название цифр десятичной системы счисления; С - несколько соединенных между собой компьютеров.
В ответ запишите найденные слова.
помогите пожалуйста

Читайте также

• Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления:


1) 164.25
2) 520,375

• Перевести данное число в десятичную систему счисления:
1) 1110010100,1011001 (двоичная СС)
2) 1000000110,00101 (двоичная СС)
3) 666,16 (восьмеричная СС)
4) 1C7,68 (шестнадцатеричная СС)
*СС - система счисления.

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших

разрядах данного числа. Пример. N = 1020000. Количество нулей равно четырем.

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.



Вы находитесь на странице вопроса "Даны числа А,В, и С .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.