Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему.ПО ПАСКАЛЬ.!!

10-11 класс

Дан одномерный массив А состоящий из 10 элементов.Вывести на экран исходную таблицу и резултат программы.
Найти произведения элементов массива А. удовлетворяющих условию:
c<=A[i]<=d.

Brain998 20 сент. 2014 г., 0:00:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Azil
20 сент. 2014 г., 2:00:03 (9 лет назад)

program kvcjkdsnfckls;

uses crt;

var a:array[1..10] of integer;

       i,c,d,p,j:integer;

begin

clrscr;

readln(c,d);

p:=1;

j:=1;

for i:=1 to 10 do

readln(a[i]);

for i:=1 to 10 do

writeln(a[i]);

for i:=1 to 10 do

if (a[i]>=c) and (a[i]<=d) then 

begin

p:=a[i]*j;

j:=p;

end;

writeln('proizavedenie=',j);

readln

end.

Честно, с таблицей не понял, но вроде все нормально. 

Программа просит ввести c и d 

Затем значения массива

Затем, по-видимому, выводится таблица

Затем высчитывается произведение подходящих элементов, и оно выводится

 

+ 0 -
Дарьяна25
20 сент. 2014 г., 3:18:57 (9 лет назад)

Если c и d задаются,  как и элементы массива,то решение вот такое

Написано в Pascal.ABC:

 

Const N=10;

var
i,c,d,k:integer;
A:array [1..N] of integer;

Begin
k:=1;
writeln('Введите c:');
readln(c);
writeln('Введите d:');
readln(d);
writeln('Введите элементы массива:');
for i:=1 to N do read(A[i]);
for i:=1 to N do write(A[i], ' ');
for i:=1 to N do
begin
if (c <= A[i]) and (d >= A[i]) then k:=k*A[i];
end;
 writeln('Произведение: ', k);
End.

Ответить

Другие вопросы из категории

Написать программу на С++. Дана целочисленная квадратная матрица произвольной размерности. Сформировать одномерный массив, в который поместить элементы

двумерной матрицы, находящиеся над побочной диагонали; упорядочить их по возрастанию и найти их среднее арифметическое.

Решите задачу в Паскале. Если можно с блок - схемой.

Дана последовательность чисел. Вывести на экран все отрицательные числа.

помогите пожалууйста)))

Читайте также

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему. Дан одномерный массив А состоящий из 10

элементов.Вывести на экран исходную таблицу и резултат программы.

Найти произведения элементов массива А. удовлетворяющих условию:

c<=A[i]<=d.

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Ребята, помогите решить задачу, пожалуйста!

Oпределите значение d после выполнения фрагмента программы:
d:=3255;
f:=d div 15-17;
z:=d div (f*5);
d:=d mod (z+1);

Помогите решить задачу пожалуйста.

Вывести на экран все числа из интервала (А, В), числа стоящие за ними, произведение этих чисел.

помогите решить задачу пожалуйста


Вы находитесь на странице вопроса "ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему.ПО ПАСКАЛЬ.!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.