Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

вычислить сумму положительных и сумму отрицательных значений функции z=cos(nx+a)sin(nx-a), где n=1,2,...10

10-11 класс

96j 12 февр. 2014 г., 2:26:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashajdnvkd
12 февр. 2014 г., 5:16:04 (10 лет назад)

Надеюсь мое решение правильное, просто не знал что делать с переменными a и x

 

Program Pr1;
uses crt;
var n,z,x,a,s1,s2:real;
Begin
clrscr;
readln(x,a);
z:=1;
n:=1;
s1:=0;
s2:=0;
while n<=10 do begin
z:=cos(n*x+a)*sin(n*x-a);
if z>0 then s1:=s1+z
else s2:=s2+z;
n:=n+1;
end;
writeln('+ ',s1:8:3,' - ',s2:8:3);
end.

Ответить

Другие вопросы из категории

Ребят, помогите, пожалуйста! В excel нужно построить на промежутке [-2;2] с шагом 0,4 таблицу значений функции: y= x в квадрате+0,2х для х меньше равно 0,

sin(0,1x) для х больше равно 0. Построить график полученной функции. Спасибо заранее

Решить задачу в паскале

Если A^2 < B^2,вычисления закончить если A^2=B^2(отпечатать текст "A^2=B^2") если A^2 >B^2 , вычислить значение функции Y=sinx+0,12 где x изменяется на интервале от 1 до 3
с шагом 0.2.Подсчитать и отпечатать количество отрицательных значений функции.

Составить программу : |x² - 4x| - x³-x²-4x

Читайте также

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0



Вы находитесь на странице вопроса "вычислить сумму положительных и сумму отрицательных значений функции z=cos(nx+a)sin(nx-a), где n=1,2,...10", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.