Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать в Паскаль.

10-11 класс

Двухмерный массив размером M*N заполнить целыми числами в интервале от 2 до 9. Вывести полученный массив на экран в виде таблицы. Найти сумму элементов кратных 2 в первых трёх столбцах.

Margotitkapony 20 янв. 2015 г., 5:23:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Viktoriya9091
20 янв. 2015 г., 7:12:12 (9 лет назад)

uses crt;
var
a:array[1..1000,1..1000]of integer;
i,j,n,m,summ:integer;
begin
readln(m);
readln(n);
for i:=1 to m do
for j:=1 to n do
a[i,j]:=random(8)+2;
for i:=1 to m do begin
for j:=1 to n do
write(a[i,j]);
writeln;
end;
for i:=1 to n do
for j:=1 to 3 do
if a[i,j] mod 2=0 then
summ:=summ+a[i,j];
writeln(summ)
end.

Ответить

Другие вопросы из категории

Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в

именах файлов символов, в которых также могут встречаться следующие символы:
Символ «?» (вопросительный знак) означает ровно один произвольный символ.
Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность.

512 Гбайт = 2? Мбайт = 2? Кбайт.
Катя, Наташа, Римма и Лиля – студентки факультета иностранных языков – увлекаются музыкой и каждая из них играет на каком-нибудь инструменте, но только на

одном: гитаре, скрипке, арфе или фортепиано.

Каждая из них учится на одном из отделений факультета: английского, французского, немецкого или испанского языка.

Та из них, которая играет на гитаре, учится на отделении испанского языка. Наташа не играет ни на скрипке, ни на арфе, и не учится на отделении английского языка. Катя тоже не играет ни на арфе, ни на скрипке и не учится на отделении английского языка. Студентка отделения немецкого языка не играет на арфе. А Римма учится на отделении французского языка и не играет на скрипке.

На каком инструменте играет и на каком отделении факультета иностранных языков учится каждая из студенток?

получается лилия играет на скрипке и не играется на гитаре, не учится на французском.

рима на французском но не играет на скрипке

наташа не на англйским и не играет не на скрипке не на арфе

катя не на английском не на скрипке не на арфе

В заданном массиве к четным элементам прибавить a .

А из элементов с четным номером вычесть b.

Читайте также

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку , добавляя после каждого символа символ '0'.

Помогите написать решение Паскаль в ALGO. Задание 1) Для заданного X вычислить значение функций: Y= 1) корень из X в квадрате, если

x=2

2) "нет решений", если x=0

3) 3x в квадрате минус 5, если X=3,4,5,6.

Задание 2) - Составить алгоритм и программу

Написать программу, которая определяет по последней цифре числа последнюю цифру его квадрата.

Прошу написать полное решение программы,

Спасибо Заранее

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

Написать программу ПАСКАЛЬ вычисления расстояния между населёнными пунктами. 1)Вычислите расстояние между населёнными пунктами. 2)введите

исходные данные

3)масштаб карты 120 (кол-во км в одном см)

4)расстояние между точками изображающими населённые пункты если между ними 3.5 (см)...(должно выйти 420км)

5) расстояние между насел. пунктами ... км

Напишите пожалуйста программу. К завтрашнему дню надо. С Паскалем проблемы



Вы находитесь на странице вопроса "Написать в Паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.