Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Вводить числа в переменную х. пока не будет введён 0.На печать ввыдать сумму введённых чисел и сами числа

10-11 класс

2003елисей2003 20 янв. 2017 г., 15:31:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elena041
20 янв. 2017 г., 16:18:01 (7 лет назад)

label nach;

uses crt;

var x,s:integer;

begin

s:=0;

repeat

nach:

write('vvedite x=');read(x);

if (x!=0) then begin writeln(x); s:=s+x; goto nach;end else s:=s+x;

until (x=0);

writeln('summa ravna=',s);

end.

Ответить

Другие вопросы из категории

Грунтовая дорога проходит

последовательно через населенные пункты А, B, С и D. При этом длина дороги
между А и В равна 80 км,
между В и С – 50 км,
и между С и D – 10 км.
Между А и С построили новое асфальтовое шоссе длиной 40 км. Оцените минимально
возможное время движения велосипедиста из пункта А в пункт В, если его скорость
по грунтовой дороге – 20 км/час, по шоссе – 40 км/час.

Помогите пожалуйста расшифровать азбуку морзе:))

Вот:U2FSDGVKX18XTOUVDEWKJXK5SPFKELTM2BOT91SH1SJRWQRHF6LC2XMWIBAFRL4J3
Или:••− ••−−− ••−• ••• −•• −−• •••− −•− −••− •−−−− −−−•• −••− − −−− ••− •••− −•• • •−− −•− •−−− −••− −•− ••••• ••• •−−• ••−• −•− • •−•• − −− ••−−− −••• −−− − −−−−• •−−−− ••• •••• •−−−− ••• •−−− •−• •−− −−•− •−• •••• ••−• −•••• •−•• −•−• ••−−− −••− −− •−− •• −••• •− ••−• •−• •−•• ••••− •−−− •••−−

Читайте также

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.



Вы находитесь на странице вопроса "Вводить числа в переменную х. пока не будет введён 0.На печать ввыдать сумму введённых чисел и сами числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.