Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите решить на С++.Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч. Через

10-11 класс

t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. Составить программу, определяющую взаимное расположение автомобилей через t1 ч после выезда грузового автомобиля.

Samp2697 06 дек. 2014 г., 7:29:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аріа
06 дек. 2014 г., 8:34:39 (9 лет назад)

#include <iostream>

int main (){
  double v1, v2, t, t1;
  std::cin >> v1 >> v2 >> t >> t1;
  double vs = v2 - v1, s = t * v1 - vs * t1;  // vs - скорость сближения, s - расстояние
  if (s > 0) std::cout << "Грузовой впереди на " << s;
  else std::cout << "Легковой впереди на " << (-s);
  return 0;
}

Ответить

Другие вопросы из категории

Сравните( поставьте знак отношения):

200 байт и 0.25 Кбайт
3 байт и 24 бита
1536 бит и 1.5 Кбайт
1000 бит и 1 Кбайт
8192 байта и 1 Кбайт

1.Написать

программу-модель анализа пожарного датчика в помещении, которая выводит
сообщение «Пожароопасная ситуация», если температура в комнате превысила 60
град. С

2.Написать
программу, которая из двух вводимых Вами чисел печатает заключение о том, какое
число больше.

нужно написать программу

y = 2 х + с ,если x>0

y = 4x^2 - c ,если x<=0

Дима, Боря и Костя отправились собирать металлолом. Они на­шли увесистую деталь, погрузили ее на тележку и повезли.

Вот нам повезло, — сказал Дима по дороге. — Эта штука из чистой меди, да и весит килограммов тридцать.
Какая там медь? — возразил Боря. — Это ржавое железо. Но ты не унывай. В нем сто килограммов будет.
Да, это явно не медь, — вмешался Костя, — а весу пятьдесят килограммов, я думаю, наберется.


Каждый из ребят оказался прав только в одном из своих предпо­ложений.

Читайте также

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Помогите решить на с++ или pascale срочно

Таймер - это часы, которые умеют подавать звуковой сигнал по прошествии некоторого периода времени. Напишите программу, которая определяет, когда должен быть подан звуковой сигнал.Входные данныеВ первой строке входного файла INPUT.TXT записано текущее время в формате ЧЧ:ММ:СС (с ведущими нулями). При этом оно удовлетворяет ограничениям: ЧЧ - от 00 до 23, ММ и СС - от 00 до 60.Во второй строке записан интервал времени, который должен быть измерен. Интервал записывается в формате Ч:М:С (где Ч, М и С - от 0 до 109, без ведущих нулей). Дополнительно если Ч=0 (или Ч=0 и М=0), то они могут быть опущены. Например, 100:60 на самом деле означает 100 минут 60 секунд, что то же самое, что 101:0 или 1:41:0. А 42 обозначает 42 секунды. 100:100:100 - 100 часов, 100 минут, 100 секунд, что то же самое, что 101:41:40.

Всем привет, помогите решить информатику.

домкумент объемом 20МБ можно передать с одного ПК на другой 2 способами:А:сжать архиватором, передать по каналу связи, распаковать. Б:передать по каналу связи без использовании архиватора. какой способ быстрее, если средняя скорость передачи составляет 2^20 бит в сек, объем сжатого архиватором документа =20%, требуемое время на сжатие 5 с, на распаковку 1 с, какой из способов быстрее и насколько

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

ПОМОГИТЕ РЕШИТЬ, НА ЛАБЕ СИЖУ!!!

Определить делится ли на целое число х целое число у без остатка. Если делится, то разделить х на у и вывести его. В турбо паскале програмку написать.



Вы находитесь на странице вопроса "Помогите решить на С++.Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч. Через", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.