Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста, очень надо, задание в файле, мой вариант №3

5-9 класс

Нужно: Ввести N чисел и рассчитать сумму положительных из этих чисел

зульфия7 28 дек. 2014 г., 20:05:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AlexRulkov
28 дек. 2014 г., 21:28:41 (9 лет назад)

[STAThread]
        static void Main()
        {
            Int32 M, N, max;
            max = Int32.MinValue;
            N = Int32.Parse(Console.ReadLine());
            for (int i = 0; i < N; i++)
            {
                M = Int32.Parse(Console.ReadLine());
                if ((max < M) && (M > 0))
                    max = M;
            }
            Console.WriteLine(max == int.MinValue ? ":(" : max.ToString());
            Console.ReadLine();
        }

+ 0 -
Alekssoft
28 дек. 2014 г., 22:05:45 (9 лет назад)

Либо файл кривой, либо у меня так тормозит, но я вместо текста наблюдаю кракозябры

+ 0 -
Nikitozzz1
28 дек. 2014 г., 23:59:09 (9 лет назад)

Комментарий удален

+ 0 -
Вика270302
29 дек. 2014 г., 2:10:31 (9 лет назад)

Не, C#, на С++ нет же классов типа Console... Кажется

+ 0 -
Kazachek2010
29 дек. 2014 г., 3:46:59 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Читайте также

Пожалуйста помогите написать 3 несложных задания...

1...Записать на языке паскаля: Условие 1) -3<x<=(меньше или равно)10;
2)x (не равно 0) ,у(не равно 0);
3)x(принадлежит) [-10;0);
4)величина x не кратна 3:

2.Cоставить программу,которая находит меньшее из трёх введённых чисел a,b,c и выводит на экран.

3.Введите три числа a,b,c.Найдите сумму двух наибольших из них.

ПОМОГИТЕ ПОЖАЛУЙСТА,ОЧЕНЬ ВАЖНОЕ ЗАДАНИЕ,ОТВЕЧУ ВЗАИМНОСТЬ...)
Огромное спасибо за ранее...

ПОМОГИТЕ, ПОЖАЛУЙСТА, ОЧЕНЬ НАДО!!!!!!!!!!!!!!!!!!!!На местном рынке ввели "гиревой сбор". Дополнительная плата с продавцов, которые используют более 4

гирь. Находчивый продавец Семен Семенович сообразил, что ему никогда еще не приходилось ничего взвешивать тяжелее 40 килограммов и понял какие 4 гири ему нужны.Определите и Вы какие четыре гири понадобятся Семену Семеновичу, чтобы он смог на чашечных весах взвесить любое количество целых килограммов от 1 до 40.В ответе укажите через пробел в порядке возрастания 4 числа - веса гирь.ПОЖАЛУЙСТА ПОМОГИТЕ!!!!!!!!!!!!!!СРОЧНО!!!!!!

Составьте программу, которая определяет, сколько раз встречаются числа x,y, x-y,x+y в последовательности из 50 заданных чисел. Данные с

клавиатурызадаются в таком порядке: x y и 50 чисел. Помогите, пожалуйста, очень надо)

Впишите пропущенное действие.Для выбора команды из вложенного(скрытого) меню надо: 1) Навести курсор

мыши на название вложенного меню 2)____________________________________.3) Перемещая мышь,выделить нужную команду в открывшемся вложенном меню. 4) Щёлкнуть мышью. Помогите пожалуйста очень надо.заранее большое спасибо!



Вы находитесь на странице вопроса "Помогите пожалуйста, очень надо, задание в файле, мой вариант №3", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.