Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Напишите па Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов

10-11 класс

массива.

Kusnesova 14 апр. 2015 г., 8:39:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Artempnev
14 апр. 2015 г., 11:25:34 (9 лет назад)

program asd;
USES crt;
Var A:array[1..100500] of integer;
i,s,n:integer;
sr:real;
BEGIN
Write('Vvedite n: ');
Readln(n);
For I:=1 to n do
 begin
 A[i]:=random(10);
 Write(A[i]:3); 
end; 
For I:=1 to n do 
 begin   
S:=S+A[i]; 
  SR:=s/n; 
 end; 
Writeln;
  Writeln('Srednee arifm. : ',sr);
END.

Ответить

Другие вопросы из категории

Два шпиона вели переписку и одному из шпионов возникла необходимость сообщить номер своего телефона состоящий из 11 цифр, тогда он написал сообщение: В

мой день рождения, собрались все наши друзья и мы играли в игру числа Фибаначчи.

Написать номер телефона первого шпиона.

Очевидно что:

1) первоклассник, семиклассник и ученик 11 класса получают разную информацию из вашего учебника информатики;
2) каждый из семиклассников, работая с одним и тем же учебником, получает разное кол-во информации.
Как вы можете это объяснить?

Читайте также

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколь

ко нулей. Разработать для программы не менее двух тестов и доказать правильность её работы.

помогите пожалуйста.....................................в течении получаса. дан целочисленный массив из 30 элементов. элементы массива могут

принимать значения от 0 до 1000.описать на русском или на одном из языков програмирования алгоритм,который находит и выводит среднее арифметическое всех элементов массива,имеющих нечетное значение

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от –1000 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, который находит и выводит среднее арифметическое всех элементов массива, оканчивающихся цифрой 5. Гарантируется, что хотя бы один такое элемент в массиве есть.

НАРОД ПОМОГИТЕ ПОЖАЛУЙСТА

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива



Вы находитесь на странице вопроса "Напишите па Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.