Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

записать программу.определение количество слов состоящих больше 3 символов

10-11 класс

Ekaterinatepechina 01 апр. 2015 г., 8:31:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zhulduzai
01 апр. 2015 г., 9:10:26 (9 лет назад)

var s:string;

n,k,i:integer;

Begin

  read(s);

  for i := 1 to length(s) do begin

    if s[i] in [" ",",","."] then begin

      if k>= 3 then n:=n+1;

      k:=0;

    end

    else k:=k+1;

  end;

  write(n);

End.

Ответить

Другие вопросы из категории

Решите, пожалуйста!!!

Ниже
записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а
потом 28.

Задачи по информатике, нужно в Паскале сделать программы:

2. Дано натуральное n. Вычислить n!; среднее арифметическое чисел от 1 до n; и среднее геометрическое от 1 до n.
3. Вводится натуральное число a. Вывести среди следующих чисел: 1;1+1/2;1+1/2+1/3;1+.......Найти среди этих чисел первое больше введёного a.

решите программу в паскаль abc

прошу, очень надо!!!

Читайте также

помогите пожалуйста:

Напиши цифровой фильтр. На вход программе подаётся строка символов. На выходе должны быть только её цифры. Например, если на входе была строка
He110, k177en!
то на выходе должно быть
110177

2. В строке, состоящей из слов, разделённых одним или несколькими пробелами, вывести второе слово. Например, если на вход программе подавалась строка
Меня истина манит сияньем
то на выходе будет
истина

На вход подаётся строка. Вывести часть входной часть строки. Часть строки задаётся номером первого символа и количеством символов.

var
s: string;
n, k, i: integer;
Begin
readLn(s, n, k);
for i := n to n+k-1 do write(s[i]);
End.


2. На вход подаётся предложение на английском языке. Вывести все гласные строки в том порядке, в котором они встречались в строке.


(ключевой фрагмент)
for i := 1 to length(s) do
if s[i] in ['A', 'E', 'I', 'O', 'Y', 'a', 'e', 'i', 'o', 'y']
then write(s[i]);


Варианты программы определения, является ли строка полиндромом
--------------------------------------------------------------
var
s, s1: string;
i: integer;
Begin
readLn(s);
s1 := '';
for i := 1 to length(s) do s1 := s[i] + s1;

write('строка ');
if s1 <> s then write('не ');
writeLn('является полиндромом');
End.



var
s: string;
i, j: integer;
Begin
readLn(s);

i := 1;
j := length(s);
while (i < j) and (s[i] = s[j]) do begin
inc(i);
dec(j);
end;
write('строка ');
if s[i] <> s[j] then write('не ');
writeLn('является полиндромом');
End.


Желательно описание хода выполнения заданий

1. Врач принимает пациентов с 8 утра до 2 часов дня. На каждого пациента отводится по 30 мин. Какое кол-во информации содержит сообщение о том, что Петя записался на приём в 11:30?
2. В детской магнитной азбуке 32 буквы. Какое количество информации содержит сообщение о том, что из них было собрано слово "муравей"
3. Какое кол-во информации получит второй игрок при игре в кретики-нолики на поле размером 8х8 клеток, после первого хода первого игрока, играющего крестиками?
4. Необходимо отгадать слово, состоящее из 5 букв и записанное с помощью алфавита 32 букв. Можно задавать вопросы, ответом на которые будет "Да" или "Нет". С помощью какого числа вопросов можно отгадать слово при оптимальной стратегии игры?
5. Алфавит некоторого языка состоит из 64 символов. За склько секунд можно передать текст из 2000 символов, если скорость передачи - 50 байтов в секунду?
6. В некотором алфавите записан текст из 300 символов, кол-во информации в тексте - 150 байтов. Сколько символов в алфавите?
7. Имеется файл с текстом из 20000 символов. При наборе текста использовался компьютерный алфавит. Текст необходимо скопировать на дискету, на которой имеется свободная область памяти 20 Кбайт. Поместится ли текст на дискету?
8. В течение 10 секунд было передано сообщение, кол-во информации в котором равно 5000 байтов. Каков размер алфавита, если скорость передачи - 800 символов в секунду?
9.Два сообщения содержат одинаковое кол-во символов. Кол-во информации в первом тексте в 2,5 раза больше, чем во втором. Сколько символов содержат алфавиты, если известно, что символов в каждом алфавите не превышает 32 и на каждый символ приходится целое число битов?
10. Сколько битов информации содержит любое трёхзначное восьмеричное число?

нужна программа на языке программирования Pascal.

Дана матрица А[8,8] четных чисел натурального ряда (от 2 до 128).
1)Заполнить и записать матрицу.
2)Определит число элементов больших 18 и меньших 60. заменить их на 0.затем записать получившуюся матрицу.
3)Определить произведение главной диагонали и вывести эти элементы на экран.
4)Реализовать определение суммы элементов любого столбца.
Спасибо.



Вы находитесь на странице вопроса "записать программу.определение количество слов состоящих больше 3 символов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.