Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

нужна программа на языке программирования Pascal.

10-11 класс

Дана матрица А[8,8] четных чисел натурального ряда (от 2 до 128).
1)Заполнить и записать матрицу.
2)Определит число элементов больших 18 и меньших 60. заменить их на 0.затем записать получившуюся матрицу.
3)Определить произведение главной диагонали и вывести эти элементы на экран.
4)Реализовать определение суммы элементов любого столбца.
Спасибо.

Malikaaaa 29 окт. 2014 г., 0:07:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sonamkrtchyan
29 окт. 2014 г., 2:00:39 (9 лет назад)

Значит так...очередная нудная программа с простым алгоритмом.

Печатает начальный массив, потом диагональ(в уже измененном массиве), потом новый массив, потом число элементов 19..59, произведение диагонали, сумму элементов столбца s.

program test;
uses crt;
var
 arr:array[1..8,1..8] of integer;
 i,j,cou,pr,s,sum:integer;
begin
 clrscr;
 randomize;
 pr:=1;
 s:=7;
 for i:=1 to 8 do
  begin
   for j:=1 to 8 do
    begin
     arr[i,j]:=random(127)+2;
     write(arr[i,j],' ');
    end;
   writeln;
  end;

 writeln;
 for i:=1 to 8 do
  for j:=1 to 8 do
   begin
    if (arr[i,j]>18) and (arr[i,j]<60) then
     begin
      cou:=cou+1;
      arr[i,j]:=0;
     end;

    if i=j then
     begin
      pr:=pr+arr[i,j];
      write(arr[i,j],' ');
     end;

    if j=s then
     sum:=sum+arr[i,j];
   end;
 writeln;writeln;
 for i:=1 to 8 do
  begin
  for j:=1 to 8 do
   write(arr[i,j],' ');
  writeln;
  end;
 writeln;
 writeln(cou);
 writeln(pr);
 writeln(sum);
readln;
end.

Ответить

Другие вопросы из категории

Упростите логическое выражение: #g*h+g*#h+#g*#h до наиболее краткой формы.

(для обозначения инверсии используется знак # перед переменной, например, #h означает h с инверсией, для обозначения логического сложения и умножения используются знаки "+" и "*"

У Васи есть доступ к Интернет по высокоскоростному одностороннему

радиоканалу, обеспечивающему скорость получения им информации У Васи есть доступ к Интернет по высокоскоростному одностороннему
радиоканалу, обеспечивающему скорость получения им информации 217
бит в секунду. У Пети нет скоростного доступа в Интернет, но есть
возможность получать информацию от Васи по низкоскоростному телефонному
каналу со средней скоростью 216 бит в секунду. Петя
договорился с Васей, что тот будет скачивать для него данные объемом 8
Мбайта по высокоскоростному каналу и ретранслировать их Пете по
низкоскоростному каналу. Компьютер Васи может начать ретрансляцию данных
не раньше, чем им будут получены первые 1024 Кбайт этих данных. Каков
минимально возможный промежуток времени (в секундах), с момента начала
скачивания Васей данных, до полного их получения Петей? В ответе укажите
только число, слово «секунд» или букву «с» добавлять не нужно.
бит в секунду.

Cоставить алгоритм и написать программу.

Найдите дискриминант квадратного уравнения:y=5x^2+6x-7

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Системы программирования:

А) обеспечивают непосредственное решение пользовательских задач;
Б) позволяют создавать новые программы на языках программирования;
В) обеспечивают работу всех аппаратных устройств компьютера и доступ пользователя к ним;
Г) обеспечивают защиту от компьютерных вирусов.



Вы находитесь на странице вопроса "нужна программа на языке программирования Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.