Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОЖАЛУЙСТА ПОМОГИТЕ!! Начертить схему, записать алгоритм и программу на языке программирования Паскаль для вычисления таблицы значений функции

5-9 класс

y=\left \{ {{5x, если x \geq 0} \atop {4x+2, если x < 0}} \right.

Для x=1,2,3,4,5,6,7,8,9,10.

{5x, если x >= 0} {4x+2, если x < 0}

Виктория2513 23 июля 2015 г., 21:45:29 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
EarlyBird
23 июля 2015 г., 22:58:06 (8 лет назад)

Решение такое (для x=1,2,3,4,5,6,7,8,9,10. ):

var
  x, y: real;
begin
   writeln('*********************');
   writeln('*    X    *    Y    *');
   writeln('*********************');
   for x := 1 to 10 do
      begin
         if x>=0 then y:=5*x else y:=4*x+2;
         writeln('*    'x,'    *    ',y,'    *');
      end;
   writeln('*********************');
end.

Но лучше сделать ввод значений х с клавиатуры:
var
   y: real; i:integer;
   mas: array[1..10] of real;
begin
   for i := 1 to 10 do
      begin
         write ('Введите ',i,'-е значение ');
         readln (mas[i]);
      end;
    writeln('*********************');
    writeln('*    X    *    Y    *');
    writeln('*********************');
    for i := 1 to 10 do
      begin
         if mas[i]>=0 then y:=5*mas[i] else y:=4*mas[i]+2;
         writeln('*    ',mas[i],'    *    ',y,'    *');
      end;
   writeln('*********************');
end.

 

Ответить

Другие вопросы из категории

305 из десятичной в двоичною
Световое табло состоит из лампочек, каждая из которых может находится в двух состояниях («включено» или «выключено»). Какое наименьшее количество

лампочек должно находится на табло, чтобы с его помощью можно было передать 50 различных сигналов?ПОМОГИТЕ!!!ПЛИЗ!!!ОЧЕНЬ БЛАГОДАРЕН БУДУ!!!!

Указать значение величины л; после выполнения следующих

операторов присваивания:
б) x := 17.5

x : = - 2 * x

не воруйте баллы,а помогите!!

Читайте также

Помогите с информатикой! Нужно cоставить программу на языке программирования (Паскаль) с ветвлением

ЗАДАЧА - Составить программу решения задачи: Z = m/(m-1)
ЗАДАЧА - Составить программу определения четных (нечетных) чисел



1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4



Вы находитесь на странице вопроса "ПОЖАЛУЙСТА ПОМОГИТЕ!! Начертить схему, записать алгоритм и программу на языке программирования Паскаль для вычисления таблицы значений функции", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.