Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль. Вводится целое число. Найти разность между суммами цифр стоящих на четных и нечетных местах

10-11 класс

Daharu 13 февр. 2017 г., 20:03:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КотБоб
13 февр. 2017 г., 22:10:53 (7 лет назад)

var

  sn, s, n, c : integer;

begin

  read (n);

  c := 0; sn := 0; s := 0;

  while n > 0 do

  begin

    if c mod 2 = 0 then s := s + n mod 10

    else sn := sn + n mod 10;

    n := n div 10;

    inc (c);

  end;

  if c mod 2 = 0 then writeln (s - sn)

  else writeln (sn - s);

end.

Ответить

Другие вопросы из категории

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не

превосходит 100 (каждое число – с новой строки), и выводит на экран число, равное произведению максимального и минимального из них, если минимальное число отрицательно; или сумме максимального и минимального из них, если минимальное число неотрицательно.

Ничего, кроме указанного числа, программа выводить не должна.

С2. Составьте программу, которая вводит с клавиатуры натуральное число N, не превосходящее 12, а затем N целых неотрицательных чисел ( каждое чисол - с новой строки), записывает эти N чисел в массив, выводит на экран сначала в обратном порядке все, без исключения, элементы массива, затем, в прямом порядке относительно следования в массиве, все элементы, остаток которых от деления на 8 равен 3.
Каждое число программа должна выводить в отдельной строке; ничего, кроме чисел, программа выводить не должна.

С3. См. фото.



Нужно написать на Паскале=))

Дан набор слов, разделенных точкой с запятой (;), который заканчивается двоеточием (:). Определить, сколько в нем слов, заканчивающихся буквой «а»

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

ЗАДАЧА В ПАСКАЛЕ дана непустая последовательность целых чисел оканчивающаяся нулем.найти: а) наибольшее число б) разность

максимального и минимального

в) максимальный элемент из стоящих на четных местах

г) сумму положительных и среднее арифметическое отрицательных

д) второй максимум

е) длину наибольшего фрагмента, состоящего из одинаковых элементов.

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО ЗА РЕШЕНИЕ ХОТЯ БЫ ОДНОЙ ИЗ ЗАДАЧЕК...))))))

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.



Вы находитесь на странице вопроса "Паскаль. Вводится целое число. Найти разность между суммами цифр стоящих на четных и нечетных местах", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.